SVN Tutorial (Mac)

Setting up the server

1. Download SmartSVN from http://www.smartsvn.com/
a. Extract SmartSVN, and open it

Steps Program Edition
- Choose the SmartSVN edition you want to use.
> Program Edition
Crash Reporting
First St | understand and agree to all terms and conditions of the license agreement
irst Steps

© Free Professional edition, for 31 days
You can use the full-featured Professional edition free of charge for 31 days.
Without registering, the feature set will automatically be switched to SmartSVN Foundation after
that period.
I Registered Professional or Enterprise edition

As a registered user of SmartSVN Professional or SmartSVN Enterprise please select the license
file you have received by e-mail after purchase.

License File:

Exit Continue

2. Agree to the terms and conditions, select the free professional edition, then click continue
a. Agree to send crash reports if you want to, then click continue

First Steps

To work with SmartSVN you will need an SVN repository. SmartSVN can assist you in
creating a repository and getting the server to run.

Steps

Program Edition

Crash Reporting

. © | want assistance in setting up the repository

> First Steps - o
My repositories are already set up

Exit Go Back | Finish

3. Select “I want assistance in setting up the repository”, and click finish



SmartSVN Professional 9.1.3 (demo until Jan 31, 2017)

Set up local repository

~R Select the empty local directory where the repository shall be created. The
repository will only be initialized now, content can be added later.

New Repository Location:
(4 Proceed with importing files into this repository

Cancel

a. Click the folder icon next to the text box

b. Navigate to your desktop, and make a new folder "SVN Tutorial"

c. Navigate into that folder, make a new folder “Server”, and click open

d. Click OK
The “SVN Tutorial” repository we’ll set up is only on your computer. There’s no way
to mess up the team repository by playing with the “SVN Tutorial” repository. You can
and should experiment with this tutorial repository!
Furthermore, if you're ever afraid of messing up the team repository, you can always
test out the action on the tutorial repository to see what it does!



Setting up the local copy

SmartSVN Professional 9.1.3 (demo until Jan 31, 2017)

el . T m By 2
Remove Move Revert Delete Fix e N R
Steps Local Directory L
il State| Local Direct Select the unversioned directory which should be imported into the
| oo Simclory repository.
Repository “
. i T~ . [;
Location Directory | /Desktop/SVN Tutorial/Local | e
Project

Cancel

1. Click the folder icon next to the text box
a. Navigate to the “SVN Tutorial” folder from before, make a new folder “Local”, and click

open

b. Click continue

SmartSVN Professional 9.1.3 (demo until Jan 31, 2017)

|  Remove Move Revert Delete Fix Changes Annotate Log Graph
Steps Repository [
al State| Local Directory Choose into what repository the specified directory should be imported.
> Repository
Location Repository: lﬁle:[llocalhost/UserslcoIinpoler/DesktoplSVN TutoriaIIServeln
Project

Cancel Go Back




2. Check the repository URL looks like the above, and click continue

SmartSVN Professional 9.1.3 (demo until Jan 31, 2017)

Steps Location

State Local Direct Choose the import location. Usually this is a directory named 'trunk’.
ocal Directory Optionally create new directories within the repository.

Repository
. HEAD of file://localhost/Users/colinpoler/Desktop/SVN Tutorial/Server
> Location
Project Directories o % | ]
Cancel Go Back | |

3. Check the list looks like the above, and click continue
a. Ifitasks “Are you sure to select a directory not named ‘trunk’?”, just click continue
4. Leave the project import options as they are, and click import

Committing changes

SVN works by keeping a master version of all the files on the server, and letting each
user work on an independent local copy. When you are satisfied with the changes
you’ve made, you’ll want to change the master version on the server. This is called
“committing”.
1. Open “TextEdit” (it’s installed on all Macs by default)
Make a new document
a. Type something, e.g. “This is my first change”
b. Save the document as “Test Document 1.rtf” in the “Local” folder we created above
3. Make another document
a. Type something, e.g. “Rocket Team is pretty cool”
b. Save the document as “Test Document 2.rtf” in the “Local” folder we created above
4. Backin SmartSVN, click the two icons highlighted below, so that icons 2,3,5,6 are selected as
below
a. As an aside, this makes the file list show all files (modified or not) and also shows only
files in the current folder (you can navigate folders in the left pane)



’ Qi e Filte
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5. Select both documents in the main file list

Files x \
Name Revision Local State A |
E Test Document 1.rtf Unversioned
E Test Document 2.rtf Unversioned
6. Modify > Commit...
eCe@
Steps Files
R itori Review the entries and provide the commit message. Only the selected entries will be @
epositories committed.
Detect Moves
i Change Path Ext.
> Flias ¥ . Add [ Test Document 1.rtf rif
Locks v & Add [3 Test Document 2.rtf rtf
2 files
= . "
| S e | Differences | | History |
Created some files with some test content..]

| Cancel | Go Back Continue

a. Check off the boxes next to the files you want to commit.
This controls which changes are sent to the server. Say you’ve made lots of changes,
but only want to send a few of them to the server (e.g. you’ve changed the nosecone,



and also the fin can, and you’re only ready with the nosecone). Here, you can select
just the files that you want to send to the server (e.g. just send the nosecone files).

b. Type in a message describing your changes.
This message describes to other users what you did, so they can search for it later. For
instance, if you change a tube length, you should say so, so that we can easily figure
out when the tube length changed.

c. Click commit

Challenge: make more changes to the files, and commit them to the repository.

Locking files

Say Alice busy working on a CAD file, and Bob starts to edit the same file. When Alice
is done, she commits her file to the server. When Bob finishes later, he tries to
commit the file, but SVN realizes he was working on an old version of the file. Since
SVN can’t intelligently combine the changes, SVN asks him whether he wants to
cancel the commit, or overwrite Alice’s changes.

How can we avoid wasting Bob’s time making changes that can’t be committed? Well,
Alice can tell the server she’s going to be editing the file in advance, so Bob knows.
That’s called “locking” the file.

1. Select “Test Document 1.rtf”, then Locks > Lock...

®@ @

Lock files for editing

The comment is optional and can be used to inform other LS
users.

Comment:
Adding content to the file|

Steal locks if necessary (might confuse locks of other users!) |
4 Update to HEAD before (only the HEAD revision can be locked) 1

Cancel | |

2. Typein a message describing why you have a lock.

Usually, it’s sufficient to say you’re editing CAD files.
Click lock

Open “Test Document 1.rtf”
Add some content to the document, and save it.
Back in SmartSVN, select “Test Document 1.rtf”, and Modify > Commit

o v kW



Files
Steps =
R itori Review the entries and provide the commit message. Only the selected entries will be DQ/
epositories committed.
Detect Moves
) Change Path Ext.
> Files ¥ ., Modify [ Test Document 1.rtf rtf
Locks
1 file
Differences v History

Commit Message:
Added some more content to Test Document 1.rtf.

Cancel

‘|_/¢_1_¢7u -l =L

a. Type a message for the commit, and click continue

Notice that you can either “Keep locks for committed files”, or “Unlock committed files”

[ JoN )
Steps Locks -
| N Decide what to do with locked files after commit. DQ/
Repositories
’ Detect Moves :
i Keep locks for committed files
Files . )
| © Unlock committed files
> Locks
|
r
1
1
2
N
\
h
Cancel Go Back [ Commit |

If you “unlock files”, SVN will release the locks on the files after you commit.

If you “keep locks”, SVN will keep the file locked for you.
a. Click cancel. (Actually, we’re going to go unlock the files)



You might choose to unlock the files if someone else needs to edit the files urgently,

and you’re not done yet. Just be aware that you’ll need to start over with the most
recent version.

8. Select “Test Document 1.rtf” again, then Locks > Unlock...

Break locks (might confuse locks of other users!)

Cancel .» J
wIneriarnucu wIieriarnucu

a. Click unlock

Challenge: get a lock on “Test Document 2.rtf”, make a change to it, and commit it to the repository

without committing “Test Document 1.rtf”. If you commit “Test Document 1.rtf”, make another change
to it, so that we have a change to experiment with in the next section.

Reverting changes

Reverting is useful when you were making a change, but you realize at some point

that you’ve made a mistake. By reverting, you can reset your local copy of any file to
whatever the server has, and just start over.

1. Select “Test Document 1.rtf” again, then Modify > Revert...

Are you sure to revert the local changes of 1 entry?

w

v\ Click Cancel to keep your local modifications.

J Revert

a. Click revert
2. Tryopening “Test Document 1.txt”; your change has disappeared!

Your change disappears because you never committed it, so the server gives you the
most recent version that was committed.

Challenge: Delete “Test Document 1.txt”. Try reverting the deleted file. (Hint: try selecting the missing
file, then Modify > Revert...)

Updating your local copy

You might update to see if any files have changed since your last update. You should
update periodically to make sure you have the latest files, and you really should
update before you make changes, so that you’re working on the latest files.



Directories x v

1. Select the repository on the left, then Modify > Update...

‘ Update working copy

s

Get the latest changes from the repository or select another %j]
‘ revision to update your working copy to.

ilﬁ Advanced

Update To: £ HEAD Revision:

Depth: = Fully recursive a

Cancel

2. Check the settings match the above figure, and click update

Getting an old version
SVN keeps all historical versions of files, so you can get old revisions too!

You may also want to limit the number of files you sync, because Rocket Team SVN
might take up a lot of space. Here’s how to do that.
1. Select the repository on the left again, then Modify > Update...



Update working copy

@ Please enter a valid revision.

Update To:

Depth: = Fully recursive

. Advanced

'HEAD © Revision:

Cancel

2. Select “Revision:”, then click the ellipsis marked above

Select a revision

1A o -

To find a revision by its commit message, start typing.

3

2
1
0

Browse Revisions at: () HEAD

Revision

Added some ... 1... coli...
Created som... Y... coli..

<No Message> Y...

" Peg Revision:

~ Commit Message Time Author Path
Made Test D... 1... coli..

fil...
fil...
fil...
fil...

Cancel

Refresh

a. Select a revision to travel back to (e.g. revision 1), and click select

3. Click update

The other file isn’t on your machine, but the server still has it. Also, next time you
commit, SVN knows not to delete the server copy.



Connecting to the Rocket Team SVN
1. InSmartSVN, Project > Check out...

Steps Repository
| > Repository Select from which repository you want to check out.
Location
Local Directory Repository: https://fedcensrv2.mit.edu/svn/Rocket_Team a
Project
Cancel me

2. For the repository, enter “https://edcensrv2.mit.edu/svn/Rocket_Team”, then click continue

Confirm server certificate for 'EDCENSRV2'

V The certificate is not issued by a trusted authority. Use the fingerprint to
validate the certificate manually: |

B3:BA:8C:FE:98:90:D6:C2:3F:DE:A1:C4:3D:06:85:6E:FF:2E:B4:3F

cancel | (IR

3. Ifit asks to “Confirm server certificate”, click confirm. This appears because we didn’t pay for a
certificate authority to endorse our certificate.

Authentication details

Please enter username and password to connect to ‘<https:// {
edcensrv2.mit.edu:443> VisualSVN Server'.

i
i

Realm: <https://edcensrv2.mit.edu:443> VisualSVN Server

User Name: cpoler

Password:

Save password

Cancel | (ST




4. Type in the username and password that you’ll be given, select “Save password”, and click login
[ JON )
Configure the master password for the encrypted password store

The master password is used to protect passwords and passphrases
which are used to authenticate with servers.

Use the following master password
Master Password:
Retype Again:

This master password is case-sensitive and should contain
lowercase and uppercase characters, digits and other
characters. Longer passwords are in general more secure than
shorter ones.

° Don't use a master password

Not using a master password makes your passwords and passphrases readable for
everyone who has access to the password file located at [Users/colinpoler/Library/
Preferences/SmartSVN/9.1/passwords. Use this option only if you are sure that this

file is safe.
cancel | (LN

a. Ifit asks to configure a master password, select “Don’t use a master password”, and
click OK. If anyone steals your computer, you have bigger problems than the SVN

server...
Steps Location
. Select the file or directory you want to check out.
Repository
> Location
Local Directory | HEAD of https://edcensrv2.mit.edu/svn/Rocket Team Show Revision...
Project Directories ez
¥ & https://edcensrv2.mit.edu/svn/Rocket_Team (28)
b 2017

Cancel Go Back

5. Make sure the full URL is selected in the location prompt, and click continue



Do you really want to check out the whole repository?

L A Usually you will only check out a certain project of the repository.

ancel Check Out

a. Ifitasksyou “are you sure?”, click “check out”

Local Directory
Enter or select a local directory, where the checked out project should be stored.

Steps
Repository

Location

<

> Local Directory Local Directory: ~/Documents/RT SVN

Project Check Out: ) Directly into the above directory
" Into subdirectory:
"I Relative to repository root
Checkout will be performed directly into the following final directory. If it does not exist yet,
it will be created automatically.

Checkout Directory: [Users/colinpoler/Documents/RT SVN

Checkout Depth: = Immediate children (files and directories) ﬁ

Cancel Go Back

Click the folder icon next to the text box
a. Navigate to your documents folder, or wherever you’d like to keep RT stuff
b. Create a folder called “RT SVN”, and click open

Confirm that “Directly into the above directory is selected”

Checkout Depth: = Immediate children (files and directories) d

Change the Checkout Depth to “Immediate children”
Click continue



Steps
Repository
Location
Local Directory

> Project

Project
Select whether to checkout a working copy or to export files only.

© Check out a working copy

© Add a new project: | RT SVN ’ ingroup: | <sorted group> B

f?‘ Add to current project

(") Don't manage as project

) Export only (don't create a working copy or a working copy metadata directory, i.e. ".svn")

Cancel GoBack | Continue

10. Make sure the settings match the above figure, and click finish

[ X N J RT SVN - SmartSVN Professional 9.1.3 (demo until Jan 31, 2017)
%7 & [ 0 e & BE 7y i
Update  Commit Add Remove Move Revert Delete Fix Changes Annotate Log  Graph Main  Revi Purchase
= [Fies « CrTa— = ]
¥ f RT SVN (Immediate ch{RELE Revision Local State ~ Remote State Change Set Copy From Relative Directory Branch
& 2017
Changes x BRI 2
Output x [l |Transactions x ‘ Q= -
v @ Check Out: revision 28 = No cached information could be found - build cache
@ 2017

You should see the repository on your machine, but there’s only a 2017 folder. Next,
we’ll sync the relevant files for you, and leave the rest out.



Directories x v

¥[s RTSVN

11. Select the 2017 folder in the navigator on the left, then Modify > Update...

Update working copy

Get the latest changes from the repository or select another “’j]
revision to update your working copy to. ’

':M Advanced |

Update To: £) HEAD Revision:

Depth: Immediate children (files and directories) B

Cancel

a. Confirm the revision is HEAD
b. Change the depth to “Immediate children”
c. Click advanced, and then select “Set depth to working copy”



Update working copy

Get the latest changes from the repository or select another &éﬁ] :
revision to update your working copy to.

Basic

(2 Set depth to working copy

This option changes the sticky depth of the working copy. It can be used to
retrieve more parts of the repository tree, and to exclude parts of the tree
from the current working copy.

Allow unversioned obstructions ("Force")

2 Include Externals

Cancel | Update |

d. Click update

Directories x v

¥a RTSVN
v 2017
Exec

Launch Ops
Outreach
Personal Rocketr
Tech Dev

12. Expand the 2017 folder, select the “IREC Rocket” folder in the navigator on the left, then Modify
> Update... (we're going to check out immediate children, just as above)
a. Confirm the revision is HEAD
b. Change the depth to “Immediate children”
c. Click advanced, and then select “Set depth to working copy”
d. Click update
13. Expand the “IREC Rocket” folder
a. Select the relevant folders for you in the navigator on the left (you can use the
command button to select multiple folders)
i. For example, if you help with Structures and Recovery, you should select
Structures, Recovery and Systems (so you can see all the latest systems info)



Directories x v

¥ RTSVN
vio 2017
) Exec (( ‘
¥ [ IREC Rocket
) Avionics
1 Design Review
[ GSE (Only
) Payload
[ Propulsion
=
o
f& Systems (Only
) Launch Ops
) Outreach \
) Personal Rocketr
) TechDev
b. Then Modify > Update... (this is not the same as above)
c. Confirm the revision is HEAD
d. Change the depth to “fully recursive”
e. Click advanced, and then select “Set depth to working copy”
f. Click update
000 [ OpenRocket
<[> B - CIERCDNNE=] Q Search
Favorites [39 Avionics » [ cAD » | 16-12-14_Raziel model.ork
- [ Design Reviews » ETETEEE ) 16-12-29_Raziel model.ork
7 Applications B GSE > | Xaphan_Blue_N2500.eng
22} colinpoler [ Payload >
o g :
[ Documents [ Structures >
© Downloads [ systems "
H Movies
J7 Music
i@y Pictures

Devices
[ Colin’s MacBo...
[Z) MacHD
[Z) BooTcAMP

Shared

e ——————————————

14. Make sure you can find all the files you need in the Finder
15. You’re connected to the RT SVN server! Have fun rocketing!



