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NIS-Elements Installation

Quick Start

Insert the installation DVD in the DVD-ROM drive. A splash screen automatically appears.
Install the selected NIS-Elements software version, additional modules, and device drivers.
Plug the provided HASP key into the USB port of your PC.
Run NIS-Elements

The DVD-ROM Content

The DVD-ROM contains the NIS-Elements software itself, Windows system drivers for all
supported cameras, drivers and utilities for HASP, documentation in PDF format, a sample image
database, and sample image sequences.

The Installation Process

Note that you have to possess the administrator rights to your computer to be able to install
NIS-Elements successfully. When the installation DVD is inserted a splash screen appears.

Select the software package to be installed. Select the one you have got the license for and which
is properly coded in the HASP hardlock key. A welcome dialog box appears. Click [Next] to
continue.
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Step 1

Define the folder where NIS-Elements should be installed. We recommend to use the predefined
directory. If you want to change the directory anyway, press the [Browse] button and select a
new one. Otherwise click [Next].
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Step 2

Now select the cameras you want to use with NIS-Elements.
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Step 3

If your licence contains some additional modules besides the NIS-Elements base software, please
select them in this window.

Note:

Any module selected will be installed along with NIS-Elements automatically. However, you might
not be licensed to use it. The module will run after you get the corresponding code registered in
your HASP key.
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Step 4

If the licence contains some device controllers listed in this window, please select them. Finish the
installation by clicking the [Install] button.
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Step 5

The setup creates a new program group containing the following items: [NIS-Elements]
application shortcut, the HASP key information shortcut, the [Modify Installation] shortcut (for
adding hardware drivers, modules, etc.), the [Uninstall] procedure, and the Send Info Tool. A
shortcut to NIS-Elements is created on the desktop too. These changes affect all user profiles of
your local Windows operating system.

Note:

Clicking the [Uninstall] command deletes all installed files from disk, and removes the
NIS-Elements program group from the Start menu as well as it removes the desktop icon.
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Additional Module/Device Installation

You may need to install a device or an additional module after the NIS-Elements main system
installation.

Go to [Start menu > Programs > NIS-Elements] program group.
Select the [Modify Installation] command.
Follow the install shield instructions. Check the checkboxes by the items you would like to 
add.
Finish the installation.

Sample Database Installation

If you chose to install the Sample Database, a new subdirectory "Databases" is created inside the
NIS-Elements installation directory (e.g. C:\Program files\NIS-Elements\Databases\...). The
"Sample_Database.mdb" file is copied to there along with database images (stored in
subdirectories). An administrator username/password to access this database is set to:

Username: "sa"
Password: "sa"

The software Copy Protection

The NIS-Elements software is delivered with a HASP hardware key.

The HASP key contains information about the software licence
and allows users to run the corresponding software. Please
connect the USB HASP after NIS-Elements installation. The
utility called "HASPinfo" is installed to the NIS-Elements
directory. It enables the user to view information about the
software licence and is accessible via the [Help > HASP Info]
menu command.
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Command Line Options

When starting NIS-Elements from the command line (or when editing the desktop shortcut
properties) you may take advantage of using the following parameters:

Syntax and example:

executable [switch1] [parameter1] [switch2] [parameter2]

["C:\Program Files\NIS-Elements\NIS AR.exe" -f "C:\Images\starting_image.jp2"]

This example command runs NIS-Elements and opens the [starting_image.jp2] at the beginning.
By default, only one instance of the application is allowed to run. When the application is running,
the command will be applied to this running instance (if the -q switch is not engaged). Some
switches do not have parameters.

Switches:

-?

Displays a help screen with the following content.

-c [Command]

The application runs an internal NIS-Elements command.

-f [Filename]

The application tries to open an image pointed to by [Filename].

-g [Grabber name]

The image grabber (driver) of the specified Grabber name will be used. No dialog box is
displayed. As the name of the grabber, you can use the name which appears in the startup driver
selection dialog, or the name of the driver class. These are listed in Windows registry
(HKEY_CURRENT_USER):

"Software\Laboratory Imaging\Platform\Platform.INI\CLxGenericProviderGrabber"

-gn

No grabber driver will be loaded.

-h [HW Unit Name]

The specified HW Unit will be used. Two HW Units (e.g. two DS-U2 cameras) can be run by one
driver. The available HW Units are listed in the [Acquire > Select Camera] dialog window. When
using this option you must also use the [-c] switch. If you do not, the application will use the one
selected the last time.

-i [Config Name]

The application creates a registry entry in "Laboratory Imaging\Platform\Config Name" to load
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from and save its configuration to.

-l [Language]

The application will run in the specified language. Us codes for the names of countries according
to the ISO 3166-1 standard.

-m [Macro File]

Application will execute the macro file (*.mac) pointed to by [Macro File].

-p [Command]

The application window will be placed according to the parameter:

When [Command] is:

[left] - the window is placed on the left monitor.
[right] - the window is placed on the right monitor.
[top] - the window is placed on the top monitor.
[bottom] - the window is placed on the bottom monitor.
[monitor N] - the window is placed on the Nth monitor.
[rectangle (x0,y0,x1,y1)] - the window is placed in the specified rectangle (in workspace 
coordinates). The coordinates must be in parenthesis without any spaces.

-q

A new instance of the application is created.
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NIS-Elements Screen

The following items appear on the screen:

The menu bar  containing pull-down menus with sets of commands.
Main toolbars (left and top)
Document toolbars (right and top)  which enable to customize the view of each opened 

image individually. See their description in the [ Document structure ] chapter.
Docked control windows  - see more description of docking windows in the [ Modifying 

Layout ] chapter.
The status bar  displaying useful information.
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Horizontal toolbar

[File > Open] invokes the open dialog window.

[File > Save] saves changes in the current document.

[File > Open/Save Next > Save Next] saves the current image as a new one according to 
the [File > Open/Save Next > Save Next Options].

[File > Print] invokes the [Print] dialog window with a print preview.

[Edit > Undo] moves one step back within the history of performed commands .

[Edit > Redo] moves one step forward within the history of performed commands.

[Acquire > Live Fast] displays the live signal  from camera. 

[Z Stack Live] displays the live signal from camera while moving the active Z drive according
to the [View > Acquisition Controls > Z Series Setup] window settings.

[Integrate] turns the frames integration ON. Number of frames to be merged can be 
sellected from a pull-down menu. 

[Average] turns the frames averaging ON. Number of frames to count the average from can
be sellected from a pull-down menu. 

[RAM buffer ON] - please see the Capturing to ring buffer  chapter.

[Capture to RAM buffer] - please see the Capturing to ring buffer  chapter.

[Acquire > Background Correction > Background Correction ON] applies the background 
correction, if it was defined.

[Calibration > Optical Configurations] displays the optical configurations  manager.

[Calibration > New Optical Configuration] runs the optical configuration wizard for creating a
new optical configuration.

Vertical toolbar

[Pointing Tool] is a default cursor which enables to move the image when zoomed in.

[Magnifier Glass] is an interactive magnifier tool for examining image details.

[View > Analysis Controls > Annotations and Measurement] opens a control window with
annotations and interactive measurement tools.

[View > Analysis Controls > Binary Toolbar] opens a control window with binary layer
modification tools.

[Applications > Define/Run Experiment] opens the ND2 capturing dialog window.
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[Acquire > Capture Time Lapse] automatically/manually opens the ND2 capturing dialog
window.

[Acquire > Capture Z Series] automatically/manually opens the ND2 capturing dialog
window.

[Acquire > Capture Multichannel] automatically/manually opens the ND2 capturing dialog
window.

[Acquire > Capture Multipoint] automatically/manually opens the ND2 capturing dialog
window.

[Edit > Copy] copies the current image to memory.

[Edit > Paste As New Image] creates a new document and inserts the image from memory.

[Image > Crop] is a tool for cropping images.

[Macro > Run Macro] runs the active macro. 

[Window > Close All] closes all opened documents.

[Edit > General Options] displays the general options dialog window.

[View > Customize Toolbar > Setup] enables to add/remove buttons to the left tollbar.

Status bar

The status bar at the bottom shows the following information (from left to right): available views,
a type of selected camera, the last performed command, the active objective name, and current
coordinates of stage and Z-drive (if connected).
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Modifying Layout

Having a well organized application layout can help you make the work with NIS-Elements very
effective. The live image, captured images, various control windows (Camera Settings,
Measurement, Histogram, LUTs, etc.) can be arranged within the application window. The control
windows can be floating or docked inside one of the four docking panes. Connecting of a
secondary monitor is also supported. User commands may be added to the main menu, and some
tool bar buttons may be added/removed.

Layout Manager

A layout in the context of NIS-Elements is a set of options describing
the arrangement of control windows, toolbars, and the menu items.
The application can operate in two modes: supporting layouts or not.
To switch the layouts mode ON/OFF, reach the [Edit > General
Options] command and go for the [Appearance] section. There is a
check box that enables/disables the mode. Once all layouts are
defined, you can make them read-only by selecting another check
box.

Blue tabs representing active layouts appear in the bottom left corner if layouts are enabled. The
[Full Screen] and [Docked Controls] layouts are placed there by default. Other layouts can be
added and managed via the Layout Manager.

If the "Read Only Layouts" box is checked, no layout changes are saved during work or on exit.

To Create a New Layout

Modify the current layout to suit your concept of work.
The asterisk appears next to the layout name (to indicate it has been modified).
Right click the layout tab and select the [Save Current Layout As] command.
Write the new layout name and confirm it by OK.
A new tab appears and the layout is saved to the list of layouts.

If you do not need to create a new layout but would like to save the changes made, just right
click the current tab (asterisk-signed) and select the [Save] command from the menu.
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To Reload Previous Layout Settings

Unwanted changes of the layout may be made. Mostly, it can be fixed by the [Reload] command.

Right click the asterisk-signed (recently modified but not saved) tab and choose the 
[Reload] command.
The application restores the last saved state of the layout.

Layout Setup

Right click any layout tab and select the [Layout Manager] command. The Layout Manager
appears.

List of Layouts

The list of currently available layouts is placed on the left side of the layout manager. Each layout
may contain information about the controls, tool bars, menu, and commands to be performed
when switching between layouts. Check the nearby boxes to select the type of information to be
included. The check marks left of the layout names indicates the layout visibility
(displayed/hidden).

The [New] button adds a new layout to the list of layouts.

The [Remove] button deletes the selected layout. The 
first two layouts cannot be deleted.

The [Activate] button makes the selected layout active 
(current)

The [Load Default] button has the same functionality as 
the Reload command described above. Except when 
applied to the Full Screen and the Docked Controls 
layouts where it loads the original settings - so they look 
just the same as after the program installation.

The [Import] button enables to load a previously saved 
set of layouts from a XML file.

The settings of all layouts can be saved to an external XML file. Use the [Export] button and 
define the destination file name.

Controls, Toolbars, Menu, and Commands of each layout settings may be modified in the right
part of the Layout Manager. Just select the appropriate name:
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Controls

The layout of docking panes and the control windows arrangement can be modified in this section
of the dialog window. There are the following tools and a preview of the layout available.

If you use two monitors, select which screen to set up (primary display, secondary display) in the
[Display] pull-down menu.

These icons turn the docking panes ON/OFF. The currently selected docking pane is 
highlighted by blue color. The splitting is indicated by the dashed line.

Each docking pane can be divided into halves by a splitting line. This button turns the the 
splitting ON/OFF.

If a two-monitor workstation is installed, this icon button allows you to select the content of 
the secondary image area of NIS-Elements. The pull-down menu contains the following 
options:

[Docking View - Horizontal Alignment] - the docked control windows will be arranged one 
below each other.
[Docking View - Vertical Alignment] - the docked control windows will be arranged on 
overlay.
[Live Window] - places the Live image to the secondary screen, and forces all non live 
windows to open in the primary screen.
[Non Live Windows] - opens all document windows except the live image on the secondary 
screen.

These buttons perform the [Shrink] and [Expand] commands on the selected docking pane.
A docking pane can be selected by clicking into the preview window.

Arranging the Control Windows

Select one of the docking panes by clicking 
into the layout preview above the [Docker 
Controls] section.
Select the tab you would like to add a control 
window to.
Click the [Add] button and select the control 
window to be added from the pull-down 
menu.
The control windows can be moved up and 
down within one tab by the arrow buttons.
The [Remove] button deletes the selected 
control window from the docking pane.

There is always one empty tab at the end of the list. When you add a control window to it,
another empty one will be created. It does not appear in the application screen.
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Toolbars

Choose the one of the toolbars 
from the [Toolbar] pull-down 
menu.
Any button of the chosen toolbar 
may be hidden by deselecting the 
nearby check box.
The [Large Buttons] option switch 
between two sizes of icons. The 
setting is shared by all toolbars.
The selected toolbar may be hidden by deselecting the [Show toolbar] check box.
The [Default] button discards changes and sets the default setting of the selected toolbar.

Main Left Toolbar

Being the most utilized toolbar of all, custom user buttons can be added to it. You can define your
own buttons which run application functions or execute macros. Select the [Main Left Toolbar]
from the pull-down menu.

Lets say that we very often use
the [Binary > Close] command.
It is useful to add a button
providing a shortcut to it to the
toolbar. Press the [Add] button,
and choose [Command] from the
context menu:

A new command (Command0) is
added to the buttons list. Now,
attach the NIS-Elements
command: Open the pull-down
menu on the right side of the
[Command] edit box and click on
the [Command List]. Choose the
command from the list (e.g.:
_CloseBinary) and confirm the
selection by [OK]. It is possible
to create a sequence of
commands, by repeating the
procedure.

If you are not satisfied with the
default icon, you can change it by pressing the [Change] button. A dialog window for selecting
the icon appears. You can select NIS-Elements icons by default, or load some others from files
containing icons (ico, dll, ...). You can define icon for the command in a disabled state, too.
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It is handy to define a tooltip (a text that appears when placing a mouse cursor over the icon) for
your command. Simply write the text into the [Tooltip] box. You can change the position of the
command in toolbar by using the arrows located under the [Add] and [Remove] buttons.

Menu

The Main Menu and the Picture Context Menu may be modified. Items of the Picture Context
Menu (the menu which appears after you right click to an image) can be hidden by unchecking
check boxes similarly to most of the tool bars.

Modifying the Main Menu

Select the [Main Menu] in 
the topmost pull-down 
menu.
Any item may be added to 
the main menu - separator,
Menu Command, a 
sub-menu (Menu Popup), 
and even a new menu 
(Main Menu Popup) - by the
[Add] button.
Select the existing menu 
item you would like to place 
the new item under.
Click the [Add] button and 
select the item type from 
the pull-down menu.
Edit the [Item Properties].

The [Default] button discards all
changes and loads the main
menu original configuration. The
[Remove] button deletes the
selected item. The arrow buttons
move the selected item
up/down.

Item Properties

[Text] - This is the text which appears in the pull-down menu. You may place the "&" sign 
before any letter. Such letter will be considered a shortcut key when browsing the menu. 
[Hot key] - one or more hot key shortcuts may be assigned to the command. Just press the 
[Add] button and press the key combination. The [Remove] button removes the selected hot
key.
[Enabled/Disabled bitmap, Command] - These fields serve for assigning a bitmap image and
a NIS-Elements function to the menu command. It works in the same way as when 
modifying the Main Left Toolbar (described above).
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Commands

These settings enable to run a command or a macro right before and after you switch to the
layout. Insert the commands similarly as it is described above.

Docking Panes without Using the Layout Manager

Docking panes are empty square spaces inside the application window, where you can place
("dock") the control windows. They can help to keep the screen "tidy". There is one docking pane
available on each side (Top, Right, Bottom, Left) and can be further divided into halves.

To Display a Docking Pane

Go to the [View > Docking Panes] submenu and select the pane you would like to display. 
The docking pane appears, either empty or with some window(s) docked.
Repeat this task to display more panes.

The same submenu can be also displayed by right-clicking into the empty application screen.

To divide a docking pane, right click inside the dockig pane and select the [Split Docker] 
command.
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To Hide a Docking Pane

Either click the arrows in the top left corner, or double click (or Ctrl + click) the empty pane (not
the docked control window). The pane minimizes to a stripe by the edge of the application. It can
be recalled to its original size by double clicking it.

 

If you would like to close the pane completely, minimize it and press the cross button, or you can
right click the pane and unselect the [Docking View] option.

To Shrink/Expand Docking Panes

Having more docking panes opened, a situation
where there is not enough room for the control
windows can occur. In that case, the Shrink and
Expand commands shall be used.

Right click the pane you would like to 
shrink/expand.
A context menu appears.
Select the Expand/Shrink command.

The commands Shrink/Expand Top, Right, Bottom,
Left are available. When one of the panes shrinks,
the neighbouring pane expands to the emptied
corner and vice-versa.

Control windows

The following control windows can be displayed within the application screen. They can be
floating, or docked inside the horizontal or vertical docking panes:

* - this control window is optional. An additional software module or a correct device connected is
required in order to display it.
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To Display a Control Window

Go to the [View] menu and 
select the desired control 
window. The controls are sorted 
to four groups: Acquisition, 
Analysis, Macro, Visualisation 
controls.
The control window appears 
floating on the screen.
To dock (and undock) it, double 
click its caption.

It is also possible to display a control window docked. Right click inside a docking pane and select
the one of your choice from the context menu. If the window is already opened somewhere (e.g.
in the opposite pane or floating), it closes and moves to the new destination.

To Close a Control Window

Click the "cross" button on the right side of the active window caption.
If the window is docked, you can also right click its caption and uncheck the appropriate 
window.
The control window closes.

Tab or Caption Style?

More control windows can be docked in the same place while only the front one is being visible.
There are two styles of displaying these windows, Tab and Caption.

Tab Style

Besides the current control window, 
the other window tabs are visible.
Switching the windows is a one click
operation.

Caption Style

All docked windows except the 
current one are hidden.
The switching and undocking of 
windows is done via the menu that 
appears when you click the arrow 
button.
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Organizer

Apart from the main application mode used for capturing and image analysis, NIS-Elements
provides a special [Organizer] mode.

Organizer was designed to ease the work with image files and
databases. To activate organizer, click the [Organizer] button
located in the top right corner of the application window or press
[F10].

The screen is primarily divided into two identical panes, each pane
switchable between two modes: the [Files] mode and the
[Database] mode. To switch from one pane to the other one use
the [View > Next Pane] command. To copy files between the
panes, simply drag the images from one side to the other side.

Files  - This button switches the pane to show a directory tree and images from the 
selected folder (and optionally its subfolders). It is called the [Files view].

Database  - This button switches the pane to show the database structure and lists images
from the currently selected database table. This is called the [Database view].

Features Available in the Files View
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This button toggles the display of the directory tree. You can switch it off to get additional 
space to display images.

In this pull-down menu it is possible to set the file type to be 
displayed. You can select a particular extension or show [All Images].

If this check-box is selected all images from the included subfolders are displayed.

Features Available in the Database View

This button displays the detailed information about the selected image. You can switch it off
to get additional space to display images.

This pull-down menu displays the active connection point and enables
to switch between connected databases.

This pull-down menu selects the active database table.
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Image Filter

Both views (Files and Database) have the option to define a filter. It enables you to display only
images which fit the defined conditions (one or two).

This button activates the filter.

Pressing this button invokes the filter setup dialog box. 

Basic mode

This mode enables you to view files that match one defined condition.

Advanced mode

This mode enables you to define two conditions with a relationship defined between them. Either
select [OR] to display files matching at least one condition, or select [AND] to display files which
match both conditions.

First, select the field, where NIS-Elements should search for a given expression. When using a
filter in the [Files] view, there are fields from file properties listed. In the Database view, the
listbox shows the names of fields from the currently selected database table.

If the selected field is of a numerical type (e.g. Size, Calibration, File date etc.) you can specify,
whether you want to find the exact value or a value in a given range. This is selected by the
[Condition type] radio button.
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If the field type is [Text], the [Occurence] setting determines the way of evaluating the
expression:

[Anywhere] - If a given sequence of characters is found anywhere in the sequence of 
characters in the field, the system will evaluate it as a match. Example: you have entered 
"set" to the [Values] field. The filter will select records with the following field values: set , 
re set , set tings, pre set , etc.
[Exact] - If the given sequence of characters exactly equals to the content of the field, it is 
evaluated as a match. Example: if "set" is entered, fields containing the set  value will 
match only.
[Start] - If the entered string is found at the beginning of a field, it is displayed by filter. 
Example: If "set" is entered, fields containing set , set tings, set up are selected.
[All letter strings] - It is possible to search for more expressions. These should be entered 
separated by commas. If you want to enter an expression with a space, insert it into quotes.
If this option is selected, only records in whose fields all of those expressions appear 
(anywhere) are selected.
[Any letter string] - This option is for entering multiple expressions as above, but this time 
every field with an occurrence of at least one from the given expressions is matched.

Operations with images

To open an image from the [Files] view, double click its thumbnail. NIS-Elements will display
it in the main window.
To select multiple images, either click on the first and the last image holding the [Shift] key 
(continuous group selection) or click individual image names with the [Ctrl] key down.
You can copy one or more images from one folder to another by "drag and drop".
This quick method can be used for inserting images to a database too. Simply drag the 
image from a folder and drop it onto the pane, where the database table is opened.
To delete selected images press the [Delete] key.

All those operations and some other can be invoked also from the context menu, which appears
each time you right click on the image thumbnail:
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Thumbnail displaying options

You can adjust the way images are shown in the organizer. Press the [Show thumbnail view
with...] button of the main tool bar and select the size of displayed image thumbnails. Selecting
the [Details with preview] option will display one image below the other with all available
information about it at the side.

There is a possibility to rotate images from within the organizer. It affects not only the
image thumbnails, but the image data too. Press the corresponding buttons.

Ordering of images

To order displayed images, right click anywhere in the pane - a context menu will appear. Move
to the [Sort by] submenu which offers several ordering criteria. If the ordering is turned ON
already, the icon is displayed on the left side of the applied criterion.

Grouping of images

To arrange the view of images efficiently, you can use the capability of grouping of images. Drag
the column name bar to the grouping bar (right above the column name bars). All files with
matching field values of the selected column will be grouped together. This can be undone by
dragging the column caption back. See the example on the Files View  picture above (the
Dimensions column is grouped).
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Adjusting the Organizer layout

The pane size is adjustable. To resize it move the mouse cursor to the dividing in line the middle.
The cursor becomes an arrow with two tips. Press the mouse button and drag it left/right to the
new position.

Resizes the panes to achieve the same size for both of them.

Resizes the pane to its maximal/minimal size (one pane is then displayed on the whole 
screen).
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Cameras

This chapter is dedicated particularly to users running the active version of NIS-Elements -
equiped with a camera. Let's assume the camera works properly, is connected to the system with
proper system drivers installed and running (if required by camera).

Selecting the driver

You will be asked to select the camera driver everytime you launch NIS-Elements. You can
change the driver later, using the [Acquire > Select Driver] command. Choose the driver that
matches your camera:

Selecting the camera

Color cameras can be used in a monochromatic mode. The actual camera type (color/mono) can
be selected by the [Acquire > Select Camera] command. Confirm the choice with [OK].

Setting up the camera

Exposure time, camera resolution, and other camera-specific features are adjustable from the
[Camera Settings] window. To invoke it, use the [Acquire > Camera Settings] command.
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Live signal from camera

This button opens a new document window with the Live-Fast image from camera. New
buttons for controlling the camera appear in the document window to control the camera.

Live formats

A camera format is a set of attributes of a video signal such as: resolution, bit depth, frame rate
etc. The live signal is a stream of image data, coming from the camera to your computer in real
time. NIS-Elements provides two different camera smodes: [Fast] and [Quality], each serving a
different purpose. The format of both modes can be set within the [Camera Settings] control
window.

Live - Fast

This tool bar button runs the [Fast] live mode. It is optimized to give as many frames per
second as possible in low resolution. This mode increases gain and uses short exposure
times.

Capture - Quality

This tool bar button runs the [Quality] live mode. It produces pictures in high resolution, but
the frame-rate is low. This mode sets the gain as low as possible and extends the exposure
time. This mode is applied every time the [Capture] button is pressed.

Capturing Images

Although it is possible to perform some procedures directly on the live image, other image
operations require [captured] or [frozen] images. If you try to perform such operation when the
live image is active, NIS-Elements automatically freezes the image. Let's see the difference
between the [Capture] and the [Freeze] commands:

This is the [Capture] button. When pressed, the camera exposure runs till the end, and the
next frame is captured and displayed on the screen. In fact, it is the first frame with the
complete exposure after you have pressed the [Capture] button.

The [Freeze] button interrupts the camera exposure, and displays the very last complete
frame.

If you are using the [Fast] mode and press [Capture], NIS-Elements will automatically switch to
the quality mode to capture the image. When the image is captured, it is opened on the screen as
a new document.
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Configuring Attached Hardware

Typically, laboratory computer image analysis systems consist of a computer, a camera, and a
microscope equipped with all necessary accessories (objectives, filters, shutters, light, rotary
changers, etc). Most of the mentioned microscopic hardware is often motorized and therefore can
be controlled by NIS-Elements. Thanks to the NIS-Elements concept, it is possible to integrate
single settings of all these devices into one compact set called an [Optical Configuration]. It is
recommended to create several optical configurations containing particular devices settings. Then
a single click can completely change the hardware configuration.

Creating New Optical Configuration

Please check that all the devices (microscopes, cameras, etc.) that you want to associate with the
new optical configuration are properly attached to the system and working. Insert a calibration
slide to the microscope.

Start the Optical Configuration Wizard

Choose the [ Calibration > New Optical Configuration ] command from the Calibration menu. The
Optical Configuration Wizard appears and the camera is automatically set to Live mode.

Type the name of the optical configuration. We recommend to use short descriptive names, 
e.g. the name of the associated objective.
Select whether to associate an objective, a camera or a microscope.
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Use the [ Camera Setup ] button to adjust the camera settings.
You can start the illumination correction process by pressing the [ Capture Correction
Image ] button.
Adjust the Microscope settings using the [Microscope Pad] and select which parts of the 
microscope shall be included in the configuration by checking them in the [Options] dialog 
box.
If there is more than one shutter and you would like to associate a shutter with the optical 
configuration, select which one is the [Active Shutter] from the pull-down menu.

Press the [Finish] button (if the Objective was not selected) or the [Next] button to continue...

Selecting Objective

Now, please select one of the following alternatives:

Select one of the already defined objectives from the pull-down menu or insert one of the 
predefined objectives via the [Insert] button. 
Or, you can create a new objective by filling its name to the [Create new objective] edit box.

Press the [Next] button to continue...
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Objective Calibration

All digitized images consist of a number of rectangular elements called pixels. A calibration
assigns real size to one pixel, so that correct and realistic measurements can be performed. It is
necessary to create a calibration for each objective because it is bound to the objective
magnification. It is possible to assign names to objective calibrations and to store them.

Select one of the following alternatives:

The [Manual] calibration lets you draw a line into a picture and define its real length (see 
below). The "On Captured" check box allows to decide whether live or captured image is 
used for the calibration. 
Having a motorized microscope, there are the [Auto] and [4 points] alternatives available.
Skip the calibration, if the selected objective (selected in the previous step) has been 
calibrated already.

Press the [Next] button to continue...

Manual Calibration

This step is dedicated to the manual calibration.

The distance is defined by placing lines (Horizontal, Vertical, Parallel) to the image. Choose 
the orientation of the lines, then click into the image to place the first line. Place the second 
line in the intended position by another click. You can modify the line position while holding 
the mouse button, not later.
When "Parallel lines" are selected, at first, define the beginning of the first line. The next 
click defines its orientation and length. When satisfied, finish the first line creation by 
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right-click. The second line can be placed by another click to the image, this time only to 
adjust the distance from the first line. The process is completed by right-click.

The following dialog box appears...

Now enter the distance between the two lines and select correct units.

Press the [OK] button to continue...

Automatic Calibration (the Auto method)

This method is fully automatic. NIS-Elements moves the motorized stage, acquires two images,
and calculates the calibration from the shift of the images.

Automatic Calibration (4 points method)

The system draws four points on the screen (subsequently) and asks user to move some
significant part of the specimen to match the points. After all four steps are completed, the
calibration is calculated from the moves of the stage.
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Optical Configuration Completion

The last status window informs you about the parameters of the optical configuration. Click
[Finish] to complete the process.

You can create more calibrations by repeating the above procedures.
The calibrations are saved to registry immediately and can be exported to an XML file 
([Calibration > Optical Configurations > Backup]).
The selected calibration is maintained. It is applied during any image input from the camera.
The selected calibration remains unchanged even if an image containing a (different) 
calibration would be loaded. The different calibration is applied to the actions regarding the 
loaded image only. 
It is possible to adjust the created calibration. Select the [ Calibration > Optical 
Configurations ] command.

Managing Optical Configurations

To display the optical configurations manager, run the [Calibration > Optical Configurations]
command. You can make the following actions from the dialog window:

Create, duplicate, rename, delete, and switch between the optical configurations.
Add, create new, edit, duplicate, delete, and calibrate objectives. 
Import and export optical configurations and the set of objectives to/from an XML file.

Optical Configurations

Once created, the configuration appears in the list and can be shared with other users by
changing the [Private] option to [Shared]*. The following settings of a selected optical
configuration can be adjusted:
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It can be deleted by pressing the [Remove] button. A confirmation dialog box appears.
Its name can be changed by the [Rename] button. The configuration name appears in the 
main toolbar (if the [Show on toolbar] option is checked).
A copy of the configuration can be made via the [Duplicate] button.
It can be turned ON by the [Set As Active] button.
Settings of all configurations can be exported to an external XML file using the [Backup] 
button.
The previously exported optical configurations settings can be loaded from an XML file via 
the [Restore] button.
The list can be ordered manually via the nearby arrow buttons.
Each configuration can be arbitrary modified within the [Details] section of the optical 
configurations window.

* - Please see the [ User Management ] chapter for details.

Details

The [Details] section enables you to completely modify the selected optical configuration. Select
whether to include the objective, camera settings, microscope setting, and one of the shutters
from the [Active Shutter] pull-down menu.

Buttons representing optical configurations are placed on the main toolbar by default. You can
remove the button of the currently selected configuration by unchecking the [Show on toolbar]
box.

Objectives and Calibrations

All images captured while a calibrated optical configuration has been selected are calibrated 
automatically.
If you need to change image calibration or you want to calibrate the image acquired via 
scanner or transferred from a digital camera, use the [  Calibration > Recalibrate Document ] 
command.
If there is no calibrated optical configuration, the simpliest way to create it is to invoke the 
[ Calibration > Quick Calibration ] command. It creates a new optical configuration 
containing a calibrated objective.
Calibration of the currently selected (active) objective can be modified via the [ Calibration 
> Recalibrate Objective ] command. The calibration procedure is described above.
The active objective name is displayed on the application status bar. Double click it to invoke 
the optical configurations settings dialog window.
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Objectives

A list of often used objectives can be created within the Optical Configurations dialog window. Any
objective can be associated with one or more optical configurations. Use the following buttons to
manage the objectives:

[Insert] - click the button and select one of the predefined objectives from the pull-down 
menu (it is ordered by the objectives magnification). 
Use the [New] button to create a custom objective. A wizard will lead you through the 
calibration process.
The [Edit] button displays a dialog window where it is possible to adjust the objective 
properties, calibration, etc. The name, working distance, numerical aperture, and the 
refractive index values of the predefined objectives cannot be changed.
If zoom is used, the objective calibration must be re-counted accordingly. Use the 
[Duplicate] button to make a copy of an objective and define the zoom factor in the dialog 
window which opens.
The [Remove] button deletes the selected objective.
The [Recalibrate] button starts the calibration of the selected objective. Please see 
[Objective Calibration] above.
The [Backup] button enables you to export the complete list of objectives to an XML file. The
standard [Save As] dialog window appears.
The [Restore] button enables you to import a complete list of objectives from an external 
XML file previously created by the [Backup] command.
The [Current unit] button invokes a pull-down menu where units for the whole application 
can be selected.
The [Create config. from objective] uses the currently selected objective to create a new 
optical configuration. Just fill in the configuration name when asked.

Units

NIS-Elements supports the following units: pixels, nanometers, micrometers, millimeters,
centimeters, decimeters, meters, kilometers, inches, and mils. If the image is uncalibrated, pixels
are the only units available. In case of a calibrated image, it is possible to select other units. All
values (e.g. measured length/area) are then displayed in the selected units. There are two ways
how to select the desired units:

Right click the status bar  of the document window where the calibration is displayed. 
Select the units and precision of their display.
Or, click the [Current unit] button located in the Optical configurations  dialog window and 
select the units.
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User Management

NIS-Elements user rights management utilizes MS Windows user accounts. Different user rights
to some NIS-Elements features can be assigned to three user groups:

Admin
Common
Guest

Run the [Edit > General Options] command and select [Users] in the left column, the following
dialog window appears:
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Lets explain the user rights on the example of layouts: Layout settings can be stored in two
places (storages): private or shared. When you create a new layout, it is set as [private]
automatically and saved to your windows account profile. Nobody else can ever use or change the
private layout. However, you can decide to share the layout with other users and set it [shared]
(within the layout manager). All users can utilize the shared items, but only members of a group
with permission to modify them can do so.

Export/Import

These buttons enable anyone to save/load complete settings of users and user groups to/from an
external XML file. Standard [Open] and [Save As] dialog windows appear. Having the data
exported may be useful when copying the settings to other computers.

Enumerate All Windows Users

This button starts copying MS Windows accounts to NIS-Elements. The accounts are assigned to
user groups (admin, common, guest) according to their Windows permission settings.

Group Settings

Select the group you would like to modify permissions of from the [Group] pull-down menu. You
have to have the [Modify users] permission to do that.

Modify users

Users can modify permissions of all groups in this dialog window, and apply the [Set active
camera as shared] and the [Set installed devices as shared] buttons.

Modify shared objectives

This option enables user to delete, recalibrate, etc. objectives within the [Calibration > Optical
Configurations] dialog window.

Modify shared optical configurations

This option enables user to modify existing optical configurations in the [Calibration > Optical
Configurations] dialog window.

Modify shared layouts

This option enables user to modify shared layouts in [View > Layout > Layout Manager] dialog
window.

Modify shared macros

This option enables user to manage shared macros via the [Macro > Manage Shared Macros]
command.

Modify shared reports

This option enables user to manage shared reports via the [File > Manage Shared Reports]
command.

Select camera

Users with this permission can select any camera driver from the [Acquire > Select Driver] dialog
window. Otherwise they are forced to use the current shared camera (below).
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Modify devices

Users with this permission can add/remove/modify devices within the [Devices > Manage
Devices] dialog window.

Set active camera as shared

This button sets the currently selected camera as default for all users without the [Select camera]
permission.

Set installed devices as shared

This option sets all devices currently listed in the [Devices > Manage Devices] dialog window as
shared, which means that other user will be able to use them. If there was a list of shared
devices before, it is overwritten by the new list.
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Images Capturing

Having all hardware accessories set up and NIS-Elements installed, you can start capturing
images. The easiest way is to capture a single image. There are also several other ways of
acquiring images, some of them specialized needing a specific hardware. They are described in
the subsequent chapters.

Single Image Capture

Turn the connected camera and other devices ON and start NIS-Elements. Select the 
corresponding camera driver.
When the application is started display the Camera Settings control window - [View >
Acquisition Controls > Camera Settings].
Switch camera to live mode - [Acquire > Live Fast] - and adjust the settings to get the live 
image clear.
Focus the objective on the scene you would like to capture the image of.
Switch to the [Live - Quality] mode and adjust its settings, especially the [Exposure time] 
and [Format]. These settings will be used every time on image capture.
Switch back to the [Live - Fast] mode. It is the usual mode for smooth work because less of 
the hardware resources are engaged.
Capture the image by pressing the capture button on the horizontal document toolbar, by 
invoking the [Acquire > Capture] command, or using the [Ctrl & -] shortcut. 
A new image is opened and named "Captured" automatically. 
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Time Lapse Acquisition

Detailed studying of long-lasting processes is enabled by the time lapse acquisition mode of
NIS-Elements. The possible experiment duration is almost limitless. Invoke the [Acquire >
Capture Time Lapse] command to set the experiment up:

Time Schedule

[The Time schedule] table enables you to define consecutive time phases where duration, interval
between single images, and number of images of the phase can be adjusted for each phase. The
Interval, Duration, and Loops settings are bound together, so you just need to set two of these
parameters. The remaining parameter is calculated automatically. Only the checked time phases
will be captured.
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Auto Focus

Automatic focusing can be used during experiment. You can select the autofocus method that
best meets your needs from the pull-down menu. The next pull-down menu determines whether
the focusing shall be performed at the begining of the whole experiment or at the begining of
each time-phase. The [Define] button shows a dialog window where you can define parameters of
the selected focusing method.

Special Options

The shutter can be closed between the acquisitions. Just check the [Close active Shutter...] box.

The [Advanced for] combo box enables to run a command (or a macro) at the begining of each
loop. You can define the command (or the macro) for all loops of one dimension or set it
individually for each loop.

You have an option to run a command* (or a macro) before and after the each image acquisition.
It is possible to type the command directly, or press the rightmost button to show the context
menu, where you can select a command from the [Command List], or search for macro files on a
disk ([Run Macro]).

* - The Live();  command can be used often. However, in some exceptional circumstances the
Live(); command may not work properly. In such case, please, use the LiveNoMsgLoop();
command instead.
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Multipoint acquisition

This feature is available when a mototized XY(Z) stage is present in the system and connected
properly. An arbitrary array of XY(Z) positions can be defined to be scanned during a multipoint
capture experiment. The Z position can be included optionally. The defined array can be saved
(and loaded later) to an XML file by the [Save] ([Load]) button. Invoke the [Acquire > Capture
Multipoint] command.

To define a multipoint array:

Move the stage to the first point (via joystick or the "Move" command).
Press the [Add New] button. The new line containing current coordinates appears in the list.
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Move to the next position and repeat the steps until you have all the intended points 
defined.

To change a single Z coordinate:

Click inside the line you would like to change.
Move the Z drive to the new position.
Click the [<-] button.

The XY coordinates of one point cannot be adjusted (unless you delete one and add a new point).

Offset All

This button appears next to the currently selected point. It can shift the XY coordinates of all
points in the same way:

Select one point of the list. (The stage moves to its coordinates automatically)
Move the XY(Z) stage to a new position (define the offset).
Press the [Offset All] button.
The coordinates of all points are overwritten (The same shift as you made with the stage is 
added/subtracted). 

Special Options

If the [Optimize] button is pressed, the system will re-order the defined points in order to
minimize the XY stage trajectory.

A grid of points aimed to be used for scanning well-plates can be defined using the [Custom]
button.

The shutter can be closed between the acquisitions. Just check the [Close active Shutter...] box.

Automatic focusing can be used during the experiment. You can select the autofocus method that
best meets your needs from the pull-down menu. The [Define] button shows a dialog window
where you can define parameters of the selected focusing method (depending on your stage
equipment and hardware drivers).

The [Advanced for] combo box enables to run a command (or a macro) at the begining of each
loop. You can define the command (or the macro) for all loops of one dimension or set it
individually for each loop.

You have an option to run a command* (or a macro) before and after the each image acquisition.
It is possible to type the command directly, or press the rightmost button to show the context
menu, where you can select a command from the [Command List], or search for macro files on a
disk ([Run Macro]).

* - The Live();  command can be used often. However, in some exceptional circumstances the
Live(); command may not work properly. In such case, please, use the LiveNoMsgLoop();
command instead.
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Z Series Acquisition

Capturing images from different focal planes of the specimen can be performed using the
[Acquire > Capture Z Series > Capture Automatically] command.

This dialog serves for setting the method of capturing in Z Series. There are the following ways of
defining the Z drive range:

Top/Bottom Position, Step

Press this button, the cube turns blue. The range is defined by the top and the bottom
position:

Run the Live camera signal, select the [Z device] (in case you have more than one 
connected) from the pull-down menu.
Set the Z range: move the Z drive to the top position and press the [Top] button, move it to
the bottom position and press the [Bottom] button.
Define the [Step] size in µm or the number of [steps] to be captured.



47

Home Position, Range

Press one of the following buttons, the cube turns yellow. The range is defined by the
home-position and the scanning range:

Symmetric mode  Define the [Range] by inserting a value in µm.

Asymmetric mode  The range is specified by two values, [Below] - the distance below 
home position, and [Above] - the distance above home position.

Run the Live camera signal, select the [Z device] (in case you have more than one 
connected) from the pull-down menu.
Move the Z drive to the position which you would like the Z drive to move around. Press the 
[Home] button to define the home position.
Specify the scanning [Range].
Define the [Step] size in µm or the number of [steps] to be captured.

Special Options

The [Reset] button discards the Top, Home, and Bottom positions settings.

The shutter can be closed between the acquisitions. Just check the [Close active Shutter...] box.

Automatic focusing can be used during the experiment. You can select the autofocus method that
best meets your needs from the pull-down menu. The [Define] button shows a dialog window
where you can define parameters of the selected focusing method (depending on your stage
equipment and hardware drivers).

The [Advanced for] combo box enables to run a command (or a macro) at the begining of each
loop. You can define the command (or the macro) for all loops of one dimension or set it
individually for each loop.

You have an option to run a command* (or a macro) before and after the each image acquisition.
It is possible to type the command directly, or press the rightmost button to show the context
menu, where you can select a command from the [Command List], or search for macro files on a
disk ([Run Macro]).

* - The Live();  command can be used often. However, in some exceptional circumstances the
Live(); command may not work properly. In such case, please, use the LiveNoMsgLoop();
command instead.
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Large Image acquisition

There is a special option in the ND2 acquisition window, to capture a Large Image. A motorized
XY stage is required to have this option enabled. When set to work, it captures several frames
within a defined area and stitches them together, so you get an extra large image. The area can
be defined in two ways:

Setting Array of Frames

Check the first radio button and define the number of rows and columns of the scanning grid.

Set the Area Size

Check the second radio button and define the size of the scanned area in millimeters.
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Fluorescence acquisition

Fluorescence (multi-channel) pictures can be acquired using the [Acquire > Capture Multichannel
Image > Capture Manually/Automatically] commands. The Multichannel setup should be adjusted
first. Run the [Acquire > Capture Multichannel Image > Multichannel Setup] command:

Channels Setup

This table defines the number and the type of captured channels. Set a descriptive name of each
channel and select the optical configuration that is to be used for its acquisition. If no suitable
configuration exists, you can create a new one by selecting the [<define new>] option from the
Optical Configuration pull-down menu. Comp. color specifies the color tone, in which the channel
will be displayed.
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Advanced ND2 Acquisition

If there are T and Z dimensions engaged in the experiment, another two columns called T Phase
and Z Phase appear in the table.

[T Phase] - the number of captured channels can be reduced by selecting [First] or [n-th] - the
channel is included in the first or every n-th time phase only.

[Z Phase] - the number of captured channels can be reduced by selecting [Home] - the channel
will be captured within the home position of each Z serie.

The phase settings can be combined in any way, but at least one channel must be included in
every frame (the [All] setting in both columns).

Manual Filter Change

The [Wait for user before changing to next channel] option enables you to switch the wavelength
filters manually during the multichannel experiment. Use this option if there is no automatic filter
changer available.

Special Options

The shutter can be closed between the acquisitions. Just check the [Close active Shutter...] box.

Automatic focusing can be used during the experiment. You can select the autofocus method that
best meets your needs from the pull-down menu. The [Define] button shows a dialog window
where you can define parameters of the selected focusing method (depending on your stage
equipment and hardware drivers).

The [Advanced for] combo box enables to run a command (or a macro) at the begining of each
loop. You can define the command (or the macro) for all loops of one dimension or set it
individually for each loop.

You have an option to run a command* (or a macro) before and after the each image acquisition.
It is possible to type the command directly, or press the rightmost button to show the context
menu, where you can select a command from the [Command List], or search for macro files on a
disk ([Run Macro]).

* - The Live();  command can be used often. However, in some exceptional circumstances the
Live(); command may not work properly. In such case, please, use the LiveNoMsgLoop();
command instead.
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Manual Capture

The [Acquire > Capture Multichannel Image > Capture Manually] command opens
a new document window with the live image and the [Capture] button. After
pressing the [Capture] button one channel is acquired. The number of channels
depends on the Multichannel Setup.

After all channels are acquired, the [Recapture] button replaces the [Capture]
button. It enables you to capture the multichannel document again. All previously
obtained multichannel data will be lost. When a single channel is selected, it can
be recaptured separately.
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Capturing to Ring Buffer (AR)

The Capturing-to-RAM technique enables user to record sequences displaying very quick actions,
lasting tens of miliseconds. The quality and number of frames in a sequence depends on
hardware capabilities of the computer system.

Set the ring buffer size

The technique uses a ring buffer to store temporary data. The ring buffer is a part of virtual
memory that is being constantly (and repeatedly) filled with the live image data. Depending on
how fast the action to be captured is, you should set the ring buffer size in miliseconds.

Click on the [Settings] command next to the RAM capture 
buttons.
Set the [Time buffered before/after] values. These represent 
the time before and after you click the RAM Capture button. 
The whole time interval will be included in the sequence. 
Confirm it by OK.

Turn the buffer ON

Click on the leftmost button of the RAM capture tool bar to enable recording of Live image to
RAM.
The ring buffer functionality is activated.

When the Camera is switched to Live mode, the left-side ring icon begins to indicate the buffer
activity. If the RAM Capture button is pressed then, the captured sequence contains frames from
the whole time interval before and after the button press. If you press the button while in the
Frozen mode or without the time buffer ON, only the [Time buffered after] sequence is grabbed.
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Capture a sequence

Press the [RAM Capture] button.
A new document window containing the captured seqence opens.
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AVI Acquisition

AVI acquisition is an easy way of recording actions in real time. It produces *.avi video files,
which can be played by any standard video player, so you do not need NIS-Elements to view the
results.

Capturing AVI movie

Display the AVI Acquisition control window the [View > Acquisition Controls > AVI 
Acquisition] command.
Adjust the advanced settings, especially define the file name and the destination folder.
Click the [Record] button. The live image appears inside the application window and is being
recorded according to the settings.
Stop recording by the [Stop] button, or wait until the time defined in the [Duration] field 
passes.
When stopped, the AVI file remains opened in a new document window.

Settings

Press the [Advanced] button to view the whole control window and set the following options:

Live

Choose the format of the camera. The
Live-Fast or Capture-Quality mode
settings will be used while capturing the
AVI movie.

Rate

The number of frames per second of the
movie can be defined. Possible values
range from 1 to 50 fps. There is also the
[Max Fps] option. When selected, the
system captures every frame sent from
a camera. If the frame rate is beyond
hardware capabilities of your system,
some frames will be omitted.

Duration

Several predefined lengths of the movie
may be selected (60 min, 10 min, 1 min,
10 s) or the [Infinite] option is available.
When selected, the movie will be
captured until the [Stop] button is
pressed or the hard drive is filled to
capacity.
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File - the path and the name

Define the path to a directory and the file name of the AVI file. If you capture more then one
movie without changing the file name setting, the other files will be numbered automatically.

File - Codec

It is common to encode (compress) movies in order to save some disk capacity. This can be done
using various types of codecs. Press the [Open] button on the right and a dialog window appears.
Select one of the codecs available in the system or use the [Default] option. Remember that the
codec you choose must be available for the AVI playback.

Video codec is a software tool which can [cod]e and [dec]ode video files. We recommend to use
one of the following codecs (FPS - maximum camera framerate which can be handled, size - size
of a reference 10s video, platform availability):

Cinepack: FPS-1.1; size-1.2 MB; availability: Windows XP + Mac
Intel Indeo: FPS-5.9; size-1.7 MB; availability: Windows XP
Microsoft YUV: FPS-14.3; size-172 MB; availability: Windows XP

Size

The size is determined by the resolution of the connected camera. However, the size may be
adjusted by the following options:

Original, 1/2 Original, 1/4 Original - sizes counted from the applied camera resolution
NTSC TV, PAL TV - standard TV resolutions
Free Size - an arbitrary [Width] and [Height] in pixels may be defined.

No matter what size is selected, the video always displays the whole scene. If the defined size
has different aspect ratio than the live image, the empty space is filled with black.

Maintain aspect ratio of

If the [Free Size] option is selected, the aspect ratio may be defined. One of the width and height
dimensions are then counted automatically.
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NIS-Elements Document Structure

Image Layers

Each NIS-Elements document can consist of the following image layers, serving different
purposes:

Annotation layer  - In this layer, graphical objects and
texts can be stored in a vector format. The results of
interactive and automatic measurements, arbitrary text
notes and other annotations are stored there.

Binary layer  - Pixels in this layer can be found in two
states only (i.e. Black/White). A binary image is usually
result of thresholding. It is used mainly for performing
automatic measurements of the thresholded objects. More
than one binary layer can be created for one image.

Color layer  - Contains image data. When you open an
image from disk, it is loaded to this layer. It can handle
images with the depth of up to 16 bits per color
component. The dimensions of this layer determine the
view of the other layers.

When saving an image, only the JPEG2000 and ND2 file format can handle all image layers and
are capable of saving them. The other image formats will save the content of the color layer only.

Document types in NIS-Elements

RGB documents

Images acquired by a color camera typically consist of three components that represent red,
green and blue channel intensities. Pixel values for each component range from 0 to 65535 (in 16
bit depth). You can display a single color channel using the tabs located in the bottom-left corner
of a document window, or an arbitrary combination of them can be selected while holding the
[Ctrl] key down.

Multi-channel documents

These documents usually arise from fluorescence microscopy. Instead of 3 color components (R,
G, B), multichannel images can be composed of many user-defineable color planes. When
a multichannel image is opened, the channel panes in the bottom-left corner are not the standard
ones (Red, Green, Blue), but are named differetly according to the channel colors.
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If there is a document that contains more than 8 components, the tabs are replaced by the
wavelength dimension, similarly to how the dimension loops of ND2 documents  are displayed.

ND2 (N dimensions) documents

The ND2 document is a set of images. There are four types of ND documents depending on the
method of acquisition: [T] for timelapse acquisition, [XY] for multipoint acquisition, [Z] for
Z-series (slices) acquisition and [Lambda] for acquisition of a defined wavelength (fluorescence
imaging). All these methods can be combined together.

Document window

Since NIS-Elements supports multiple windows, all controls affecting the view of the image
(layers, channels, etc.) are located in every image window. Therefore it is possible to control each
opened image individually.
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LUTs

[Enable LUTs] button applies LUTs  to the image.

[Keep Auto Scale LUTs] button applies the AutoScale command to the image continuously.

[Auto Scale] button performs automatic setting of LUTs .

[Reset LUTs] button discards the LUTs settings.

Split components

[Split Components] button turns ON a special view, where color channels of the image are 
tiled.

Zoom controls

[Fit to screen] button adjusts zoom to view the whole image within the NIS-Elements 
screen. It corresponds to the [ View > Zoom > Fit to screen ] command.

[Best Fit] button adjusts zoom to fit the NIS-Elements image window in one direction but to
fill the screen. Corresponds to the [ View > Zoom > Best Fit ] command.

[1:1 Zoom] button adjust zoom so that one pixel of the image matches one pixel of monitor.
It corresponds to the [ View > Zoom > 1:1 Zoom ] command.

[Zoom In] Increases magnification of the image. It corresponds to the [ View > Zoom > 
Zoom In ] command.

[Zoom Out] Decreases magnification of the image. It corresponds to the [ View > Zoom > 
Zoom Out ] command.

General controls

[Show Probe] button activates the probe. The probe affects histograms, auto exposure and
auto white balance functions.

[Show Background Probe] button activates the background probe. Some commands (Image
> Background > Subtract Background) uses the BG probe data as reference.

[Show Grid] button displays the grid for rough measurements.

[Show Scale] button displays the image scale.

[Show Frame] button displays and applies the measurement frame.

[Show Measurement ROI] button displays the Measurement Reagion Of Interest.
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[Show Profile] button displays the [View > Analysis Controls > Intensity Profile] control
window. It alows you to specify a linear section in the image of which the pixel intensities 
graph will be created.

Right click the icons to invoke a context menu where properties of each tool can be modified.

Status bar

The status bar at the bottom of the application window displays the following information (from
left to right): image calibration, pixel coordinates of the mouse cursor along with channel
intensities, color mode, bit depth, and picture size in pixels.

Working with Vector Objects

There are two types of vector objects which can be placed over the image: annotation and
measurement objects.

Annotation Objects

This button toggles viewing of the annotation objects (text notes, arrows, etc.).
Right-clicking the button displays a context menu with the following options:

[Clear All Objects] will delete annotation and measurement objects. 
[Select Annotation Objects] will select all objects that are not the measurement ones.
[Select All Objects] and [Deselect] will select/deselect all annotation and measurement 
objects.

Measurement Objects

This button toggles viewing of the measurement objects of the interactive and automatic
measurements. Right click it to display a context menu with the following options. The [Clear
All Objects], [Select All Objects], and [Deselect] options work the same as described above.
There are two different options:

[Remove Automatic Measurement objects] will remove only objects created by automatical 
measurement.
[Select Interactive Measurement objects] will select all measurement objects created by 
hand.
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Working with Binary Layer

This button turns on the view of a binary image. It can be edited by hand using the [ Binary
> Binary editor ] command, or by pressing the [Tab] key.

The binary layer can be displayed together with the color layer using the overlay mode. A
number of binary layers can be created for one color image. Manage them using the [View >
Visualization Controls > Binary Layers] control window.

This button switches to view of a color image.
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ND2 files

A special document type consisting of one or more image sequences is a so-called ND
(n-dimensional) document. N-dimensional experiments combine up to 5 acquisition types
together: Z series, time-lapse, fluorescence (Lambda), multipoint, and large image. The resulting
image sequence (*.nd2 file) includes information about the experiment structure and its
progress.

ND2 Acquisition

All the four dimensions* can be combined together creating a 6-dimensional ND document
(dimensions: X, Y, Z, multipoint, time, wavelength).

Run the [Applications > Define/Run Experiment] command.
The following control window appears.

Select one or more dimensions (tabs) which should be included in the resulting ND2 file. 
Above the tabs, there is a preview of how the nd2 file structure will look like.
Set the parameters of each dimension acquisition. **
Select whether to save the ND document directly to a file or just to keep it in memory to be 
saved later. The path and the file name shall be defined if saving to a file is preferred.
Click the [Run now] button to start the acquisition.

* - Two of the four available dimensions can be combined in the Basic Research package.

** - Please see the Timelapse- , Multipoint- , Z series- , Fluorescence- , and Large Image
Capturing  chapters for further details.
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Save to File

An image can be captured and saved manually after the experiment is finished, or it can be saved
to harddisk "on the fly":

Check the [Save to File] box. The dialog window reveals an extra section.
Insert the [Path] or use the [Browse] button to define the destination folder.
Specify the [Filename]. 

Record Data

The nd2 file contains various [Recorded Data] which carry e.g. acquisition times of single frames.
Some of them can be recorded optionally:

Press the [Recorded Data] button. A pull-down menu appears.
The data to be recorded are check-marked.
To view the recorded data of an opened ND2 file, invoke the [File > Image Properties] 
command.

Browsing ND2 document

When an ND2 file is opened, its structure is pictured at the bottom of the document window.
There is a time line with all captured images indicated by gray markers. The blue-highlighted
marker idicates the currently observed image. Below the time line, there is one row of blue
rectangles for each dimension. Blue rectangles stand for single phases of each experiment
dimension. In case the multichannel dimension is included, the channels are indicated by the
color tabs at the very bottom of the document window.

ND Control Bar

Browse the ND document by clicking inside the time line - single time phases are highlighted by
the alternating red and blue background. You can also display a frame by selecting the
corresponding blue rectangle. There are other ways how to observe the ND document using the
following buttons:

Insert User Event

This button inserts a marker to the current frame. User events can be pinned to any of the
frames of the document in order to highlight a remarkable scene. There are number of
event types. Some of them are inserted automatically (marked with *) while the ND
experiment is running, others must be defined by user:
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Autofocus performed*
Command event*
Pause experiment*
Resume experiment*
Cancel experiment*
Acquisition zero time*
Next phase*
Experiment paused for refocusing
Macro event
Event from macro
Stimulation
User event 1, 2, 3, 4

Once there is one or more events within the time line, you can manage them via a context menu.
Right click the event marker, a menu appears with the following options:

Remove All Events
Event Playing Range
Event Manager
Remove Event
Edit Event

When you open the [Event Manager], all events within the ND document may be edited through
the following window. The time can be put in, and the event type selected from a combo box.

User Event Selection

This button does a selection of frames of the ND file according to the [Event Playing Range]
settings. Right click an event marker and pick the [Event Playing Range] command from the
context menu.

A simple dialog window appears. Define the number of frames/seconds which will be selected
around each event. It is specified by a single value (absolute selection size) or by the before/after
values (asymmetric range).



64

Range Selection

Clicking this button selects a user defined range of frames. The selection is done by mouse.
A range can be selected by mouse while holding the [Shift] key down. Single frames can be
added/removed by mouse while holding the [Ctrl] key down similarly as when using
Windows Explorer.

ND2 files may contain extremely large number of frames. It may be helpful to omit some of the
frames from the selection. Right click the [Range Selection] button and a context menu appears.
It enables you to select every 2nd, 5th, 10th, 20th, 50th, 100th frame. The [Select All Frames]
option selects the whole range of frames as if you selected the first and the last time phase with
the [Shift] key down, but preserves the [Select Every...] setting.

Disable Selection

Press this button to deselect all frames of the ND document.

Playing options

[Play Sequence] displays the selected/all images of the browsed dimension.

[Stop Playing] stops playing the sequence at the current frame.

[Previous Position] displays the previous frame of the browsed dimension.

[Next Position] displays the next image of the browsed dimension.

[Increase Playing Speed] - the speed ranges from 0.5 FPS to 500 FPS.

[Decrease Playing Speed] - the speed ranges from 0.5 FPS to 500 FPS.

[Real Time Playing Speed] sets the playing speed to real-time (as the document was 
captured).

[Maximum Playing Speed for Every Frame] sets the playing speed to maximum while the 
display of every frame is guaranteed (when the speed is set to maximum by the + button, 
some frames are usually omitted when playing the sequence depending on your graphic 
card).

[Home Position] displays the frame of the Z dimension that was set as "home" during the 
acquisition.
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Observing ND2 Data Sets

There are several views that can display the ND2 data sets in different ways. When you switch
the view, a new document window opens. Some views are available for some dimensions only. If
a view is available for two or three dimensions of the ND document, a pull-down menu appears in
the top document tool bar. There you can select the dimension to be displayed.

Main View

When you open an ND2 file, it opens in this view.

Maximum/Minimum Intensity Projection View

Available for Z, T. These projections analyse all frames of one dimension and pick pixels
with the maximum/minimum intensity values. These pixels are used in the resulting
image.

Slices View

Available for Z, T. This view displays orthogonal XY, XZ, and YZ projections of the image
sequence.

Volume View

Available for Z. This view creates a 3D model of the acquired object.

Tiled View

Available for Z, T, and Multipoint. This view displays frames of the selected dimension
arranged one next to other.
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Examples:
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Synchronizer

Synchronizer enables to compare (run
and view) two or more N-Dimensional
documents. It automatically
synchronizes view of all documents
added.

To add ND documents to Synchronizer

Open at least two ND documents you would like to observe.
Use the [Add All] button (the first one) to add them to the synchronizer. In case there are 
more documents opened, use the [Add Current View] button (the second one) instead. The 
ND2 file being added must be active.
The names of selected documents appear in the View Synchronizer window.

To observe synchronized documents

All documents added to Synchronizer are automatically being synchronized.

Set one of the selected documents active.
Any action regarding the view (Z position, displayed frame, etc.) is performed on the other 
documents as well as on the active one.

To remove a document from View Synchronizer

To remove one document from the synchronizer, click the check box next to its name.
To empty the whole synchronizer, click the [Remove All Views] button (the third one).

Processing of ND2 Documents

Most of the image processing and binary
image processing commands can be applied
to one image, all images, or selected
dimension of the ND2 document. When you
use such command with ND2 file, the
following options are added to its dialog
window:

Single Image

The operation is performed on the current
frame of the ND2 document.

All Images

The operation is performed on all frames of the current ND2 document.
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Selected Dimension

The operation is performed on all frames of the selected dimension.

E.g. When you have a document containing T and Z dimensions. Selecting the Z-Series dimension
performs the operation on all Z frames of the current T dimension.
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Working with Documents

It is possible to work with multiple image documents opened at the same time. The
Multi-Document Window Environment ensures that every document is opened to a single window
that contains the most used controls affecting the image appearance (Layers, LUTs, Zoom etc.).

Opening Saved Files

NIS-Elements offers several ways to open an image file:

Using the Open dialog-box

To invoke the Open dialog box, you have the following options:

Select the [File > Open] command...
Press [Ctrl + F12] keys simultaneously...
Press the [Open] button located at the beginning of the application main toolbar...

Using Organizer

An image can be opened by double clicking its filename within the
Organizer layout. Please see the [ Organizer ] chapter for more
details.

Using the Recent files list

You can quickly access the last opened images using the [File > Recent files] submenu. The
number of the files listed in the submenu can be adjusted in the [Edit > General Options]
window.
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Using the Open next/previous/first/last commands

These commands enable you to continuously open the next/previous images from a particular
directory or a database table. This is useful when editing multiple files placed in one directory.
The commands are located in the [File > Open/Save Next] submenu. You can define sorting,
filtering and other features in the [ File > Open/Save Next > Open Next ] settings dialog box.

Straight from Windows explorer

During installation, NIS-Elements creates file associations to files that are considered a native
format for storing images (JPEG2000, ND2). The JPEG2000 (JP2) and ND2 image files can be
then opened in NIS-Elements just by double clicking their names in Windows Explorer.

Switching between loaded documents

The commands for managing the opened images are
grouped in the [Window] menu. The presently
opened files are listed in its bottom part. The
currently displayed image is indicated by a check
mark. To change the current image, select it from
the list or use the [Next] or the [Previous] command
(represented by [Ctrl + Tab] and [Ctrl + Shift + Tab]
shortcuts). Another possibility is to arrange
document windows automatically using the [Tile
horizontally] or [Tile vertically] commands. This will
change the size and position of the opened
documents and they will be aligned ordered in the
selected direction.

Closing documents

The currently displayed image can be quickly closed by pressing the cross button, located in 
the top-right corner of the document window.
The image can be also closed by invoking the [Window > Close] command or by pressing 
the [Ctrl+F4] shortcut.
If you want to close all images, use the [Window > Close all] or the [Ctrl+Shift+F4]
shortcut.
If you try to close an image that has been changed, NIS-Elements will display a confirmation
dialog box, offering to save the changes.
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Image Formats

NIS-Elements supports the following number of standard file formats. In addition, NIS-Elements
uses its own image file formats to fulfil specific application requirements.

JPEG2000 Format (JP2)

An advanced format with optional compression rates. Image calibration, text descriptions, and
other meta-data can be saved together with the image in this format.

ND2 Format (ND2)

This is the special format for storing sequences of images acquired during ND experiments. It
contains various information about the hardware settings and the experiment conditions and
settings.

Joint Photo Expert Group Format (JFF, JPG, JTF)

Standard JPEG files (JPEG File Interchange Format, Progressive JPEG, JPEG Tagged Interchange
Format) used in many image processing applications.

Tagged Image File Format (TIFF)

This format can save the same amount of meta-data as JPEG2000. TIFF files are larger than
JPEG2000 files but are loaded faster. TIFF files have several ways to store image data, therefore
there are many versions of TIFF. NIS-Elements supports the most common TIFF modalities.

CompuServe Graphic Interchange Format (GIF)

This is a file format commonly used on the Internet. It uses a lossless compression and stores
images in 8-bit color scheme. GIF supports single-color transparency and animation. GIF does not
support layers or alpha channels.

Portable Network Graphics Format (PNG)

This is a replacement for the GIF format. It is a full-featured (non-LZW) compressed format
intended for a widespread use without any legal restraints. NIS-Elements does not support the
interlaced version of this format.

Windows Bitmap (BMP)

This is the standard Windows file format. This format does not include additional image
description information such as author, sample, subject or calibration.

LIM Format (LIM)

Developed for the needs of laboratory image analysis package. Nowadays, all its features (and
more) are provided by the JPEG 2000 format.

ICS/IDS image sequence

ICS/IDS sequences are generated by some microscopes and consist of two files: the ICS file with
information about the sequence; the IDS file containing the image data. The ICS file must be
stored in the same directory together with the IDS file.
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Histogram and Look Up Tables

Histogram Window

A histogram is a graphical display of tabulated frequencies. In NIS-Elements, it displays
frequencies of pixels with a certain intensity value. The intensity values range from 0 (black) to
255 or 65535 (white) depending on the image bit depth. A separate graph is created for each
color channel. Run the [View > Visualization Controls > Histogram] command:

Histogram tools

Source data of the histogram can be viewed by switching the tabs in the bottom-left corner of the
control window.

Export

The source data or the histogram image can be exported to an external file. Click the
[Export] arrow button to select a destination from a pull-down menu.

Please, see the Exporting Results  chapter for further details. The source data table will appear if
you click the [Data] tab at the bottom of the control window.
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The [Export ND histogram] button enables to export histogram data of all frames of the
current ND document. The destination selected in the [Export] pull-down menu is
maintained.

Graph appearance

The histogram can be zoomed in and out using the zoom buttons on sides of the window, or
autoscale buttons can be used:

[Auto Scale Vertical] zooms in the graph of each channel separately. When this function is 
ON, the histogram is not proportional.

[Auto Scale Horizontal] zooms the graph so that the marginal zero frequencies, if there are 
some, are excluded from display. 

The graph appearance can be modified via the following buttons:

[Show Grid] toggles display of the grid in the background.

[Options] displays the Histogram options dialog window where the following properties can 
be set:

Background/Axes Color  - the colors can be selected from a pull-down menu.
Pen Width  - width of the histogram line can be set to 1, 2, or 3 pixels.
Fill Graph Area  - The area below the histogram line can be filled with the channel color.
Graph Area Opacity  - select the opacity of the Graph Area fill in [%].
Vertical/Horizontal AutoScale, Show Grid  - these options equals the corresponding 

buttons of the histogram window.
Interpolation method  - select the way of drawing the graph line. The [Linear] (smooth) 

and [Quick] (precise) options are available.
AntiAlias  - smoothes the edges of the graph line.
Horizontal axis always visible  - if checked, the axis does not leave the graph area while

zooming in the graph.
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LUTs

A look-up table represents a useful tool for color modifications. It takes a value, maps it to a
location in a table, and replaces the incoming value with the contents of the table entry. There
are 3 modes of LUTs, depending on the image you are working with. Different controls will be
available when applying LUTs to monochromatic, RGB, or multichannel image. When LUTs are
activated the LUTs button in the top-left corner of the document window  is highlighted red.

LUTs on RGB images

The main part of LUTs window is occupied by a histogram of the current image. There are 3
separate curves for each RGB component, and one gray filled curve for the whole image. You can
adjust the histogram view by moving the slider in the left part of the window.

The black and white triangular sliders define thresholds. All the pixels with values smaller than
the black slider indicates (left of the slider) will be displayed as pure black. All values to the right
of the white slider (all pixels with higher values) will be displayed as white. The remaining color
shades will be composed of the pixels with values between the two sliders with defineable gamma
parameter. Gamma is adjustable by moving the gray slider.

This button extends the sliders and displays the histogram as if LUTs was applied. The range
of pixel values currently displayed becomes indicated in the top right corner.

Three color bars with sliders (displayed underneath the histogram) are representing RGB
components. The slider movement affects the brightness of each component.
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Auto scale

The [Auto Scale] button sets the white slider parameter automatically in order to enhance
the image reasonably. If you select the [Use Black Level] option from the pull-down menu,
the black slider will be affected too. If you select the [Find Best Gamma] option from the
same menu, the Gamma slider position will be optimized as well.

It is possible to apply the auto scale procedure only once by pressing the [Auto Scale]
button, or to run it permamently (on the live image) by selecting the [Keep Auto Scale]
button. When you turn the Keep Auto Scale off, the settings remain as if the [Auto Scale]
button was pressed once.

If you want to discard all LUTs settings, press the red cross button, located next to the [Auto
Scale] button.

Settings

Press the arrow next to the [Auto Scale] button, a pull-down menu will appear. Invoke the
[Settings] command.

[Quantile (0-10%)] - this value determines how many of all pixels of the picture are left outside
the sliders when LUT is applied.

AWB

The AWB (Auto White Balance) mode adjusts the image to get the color neutral white. Similarly
as the LUTs auto scale, it can be used once, or permanently on the live image by selecting the
[Keep Auto White Balance] checkbox left of the [AWB] button. When you uncheck the box, the
settings remains as if the [AWB] button was pressed once.

If you know which undertone your white has, you can select this color by the color picker that
appears after pressing the [...] button on the right of the [AWB] button. And again, all changes
are discarded using the red cross button.

The color overexposed button. When this button is activated, all pixels values of which reach
maximum will be color-highlighted.

Press this button to apply the LUTs settings to the image data - the original image will be 
owerwritten. Until you press this button, no changes are made to the image data.
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LUTs on Monochromatic images

All features mentioned above are also valid for monochromatic images. When adjusting a
monochromatic image, you don't have the AWB function available and only one bar with sliders
for the mono channel appears.

Mapping Mode

This pop-up menu is used for pickng the mode of mapping. You can select from [Contrast] or
[Window] modes.

[Contrast] - all pixels with values higher than the white slider will be set to white.
[Window] - all pixels with value higher than the white slider will be set to black.

Color Schemes

This button indicates the selected color table and displays a pull-down menu, where you can
select the color scheme in which you want to display your image. Try a few of the schemes to see
which one highlights most of the details you want to see.
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LUTs on Multichannel images

In case of multichannel image the histogram shows different color curves - each color for one
color channel. To set LUTs for a single channel, this channel must be selected in the pull-down
menu at the bottom of the LUTs window.

Auto Scale

A single channel can be adjusted automatically using this [Auto scale] button.

Look-up tables are useful for equalizing images. For example, if the image is very dark (which
usually happens with quantitative cameras), you can restrict the view to display just the low pixel
intensities. Hidden details then become more apparent.
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Thresholding

Specifying correct threshold limits is a crucial procedure of the automated image analysis. The
point is to determine, which pixels will and which will not be included in the binary layer, and
thereby distinguish analyzed objects from background. Thresholding can be performed in the
following modes:

Run the [View > Analysis Controls > Thresholding] command.

RGB Mode

The [RGB] thresholding mode is available only if an RGB image is opened. There are two ways
how to define the threshold limits, by choosing reference points within the image, or by defining
the limit values for each color channel.

To threshold the image use the following
tools:

This button invokes a pull-down 
menu which enables to load/save 
the current threshold settings 

from/to an external file 
(*.threshold).

This button displays/hides the 
[Size] and [Circularity] restriction 
bars.

Single point threshold tool. Select it 
and click inside the image to define 
the threshold. The threshold ranges 
will be adjusted so the selected 
pixel will fit inside.

3 point circle tool picks threshold 
from the radius of 3 pixels.

6 point circle tool picks threshold 
from the radius of 6 pixels.

This button erases the threshold 
settings (no binary objects are 
created).

Undo - reverses the previous 
threshold operation.

Redo - returns the threshold as it 
had beed before the [Undo] button 
was used.

Rethreshold once - after you press this button, the current binary layer will be re-created 
according to the current threshold settings.* 
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Keep updating the binary layer - If turned ON, the binary layer is updated during some user 
actions.**

Threshold ND image - when an ND2 file is opened, this button appears in the tool bar. The 
thresholding is performed on a single frame by default. Press this button to perform it on all 
frames of the ND2 document.

* - The binary layer could have been modified e.g. by the [Binary > Clean] command or other
commands; all these modifications will be discarded.

** - When a new image is opened, the binary layer is created automatically. Or, when
thresholding inside the Measurement ROI and the ROI is moved, the new ROI area is
thresholded.

Threshold adjustments

Thresholding parameters can be adjusted very precisely in the following way:

Threshold limits of each channel can be adjusted by rewriting the values in the 
top-left/top-right corner of each channel histogram.
Threshold range of each channel (the colored stripe) can be shifted by mouse. Place the 
cursor in the middle of the range (a circle appears) and drag it left or right. 
Threshold limits of each channel can be adjusted by mouse. Place the cursor on the edge of 
the range and drag it left or right.

The two last behaviours can be further modified by pressing additional keys:

Move the threshold using the right mouse button  - the binary layer in the image is 
not updated continuously, but after the mouse button is released. Such operation is quicker.
Hold [Shift] while moving the threshold limits  - the threshold adjustment is 

performed on all channels together (RGB images only).
Hold [Ctrl] while moving the threshold limits  - both the low and the high threshold 

limits move in opposite directions.

Binary operations

Three basic operations can be performed on the binary layer before it is displayed on screen. To
turn the operation on, click on the up arrow button in order to define the number of its iterations:

Clean - removes small objects from binary image.
Smooth - smoothes the binary image contours.
Separate - separates objects using mathematical morphology methods.

Restrictions

The amount of objects that appear within the binary layer can be restricted according to their
[Size] and [Circularity] features. The restrictions can be defined by moving the sliders to the
center of the bar. The actual limits appear in a tooltip when moving the sliders.



80

Size - defines the minimum and the maximum size of the objects to be displayed.
Circularity - is a coefficient which defines how much the object is similar to circle. The range 
is from 0 to 1. 
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HSI Mode

The [HSI] thresholding mode is available only if an RGB image is opened. The thresholding
procedure works the same way as in the RGB mode except that the pixel values are displayed in
the the HSI (Hue, Saturation, Intensity) color space.

The only difference from the RGB mode is that the [Saturation] and [Intensity] channels can be
switched OFF. Therefore you can threshold over the H, HS, and HI channels only. Switch the
channel off by unchecking the box in the top-left corner.

Intensity Mode

The thresholding procedure works the same way as in the RGB mode except that it is performed
on the intensity pixel values.

MCH Mode

The [MCH] mode is not available when working with a monochromatic (single channel) image.
This mode is dedicated to perform threshold on multichannel images, but can be applied to RGB
images as well.

There can be number of channels, therefore the channel histograms are minimized. To 
expand a histogram, click the appropriate color stripe.
The binary layer(s) can be displayed in two modes. Each channel can create its own binary 
layer, or one layer can be created as an intersection of all channels binaries. The following 
button indicates one of the two modes:
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Binary Editor

The binary layer, as a result of thresholding, can be modified by hand using the binary layer
editor. It is a built-in application providing various drawing tools and morphology commands. Go
for the [Binary > Binary Editor] command or press the [Tab] key. New controls appear on the
application toolbars:

Controls (horizontal tool bar)

Reverses the changes made to the binary image. [U]

Clears the binary image (fills the entire image with the "background" color). [R]

Loads the image previously saved by the [Save] button. [L]

Temporarily saves the current binary image. It can be loaded anytime before the binary
editor is closed by the [Load] button. [S]

Displays this help page.

Stores the changes and quits the editor. [ESC] or [TAB]

The other buttons of the vertical tool bar are simplified versions of mathematical morphology
functions. Please see the Mathematical Morphology Basics  chapter for more details.

Dilate

Erode

Close

Open

Separate Objects

Clean

Fill Holes
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Drawing tools (vertical tool bar)

The binary image can be modified using various drawing tools. Although the way of use of some
tools differs, there are some general principles:

Make sure you are in the right drawing mode (drawing background/foreground)
Any object that has not been completed yet can be canceled by pressing [Esc].
The polygon-like shapes are drawn by clicks of the left mouse button. The right button 
finishes the shape.
The auto-drawing tools (threshold, auto detect) have a changeable parameter. It can be 
modified by +/- keys or by mouse wheel.
The scene can be magnified by the UP/DOWN arrows when mouse wheel serves another 
purposes.
The right mouse button drags the image when magnified.
A line width can be set in the upper left corner.
Hints are displayed below the horizontal tool bar.

Drawing tools

Switches between the foreground and the background editing mode. [Ctrl+SPACE]

The Hand tool. Serves for moving the image when magnified. [Ctrl+W]

Bezier hollow tool. The object is defined by placing points on its perimeter. The lines
connecting those points can vary from straight lines to bezier curves. (Use +,- keys to 
adjust them). To finish creation press the right mouse button. [Ctrl+F11]

Bezier fill tool. It equals the Bezier hollow tool, but the resulting object is filled. [Ctrl+F12]

Draws a filled polygon. While holding the left mouse button down, you are in the free hand
mode. When you release it, each click defines a corner of the polygon. The polygon is 
enclosed and filled by pressing the right mouse button. [F4]

Draws a polygon. It equals the Filled polygon tool, but the resulting object is not filled. [F3]

Draws a filled circle. Click to determine the center and define the perimeter holding the left
mouse button down. [F8]

Draws a circle. Click to determine the center and define the perimeter holding the left
mouse button down. [F7]

Draws a filled circle defined by three points placed on the perimeter. [Ctrl + F8]

Draws a circle defined by three points placed on the perimeter. [Ctrl + F7]

Draws a filled rectangle. [F10]
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Draws a rectangle. [F9]

'Draws a filled moveable circle/ellipse. If you grab the ellipse near the center, you can move 
it. If you grab it near the border, the nearest semi-axis is being modified. When holding 
down either the SHIFT or the CTRL key, both semi-axes change equally (forming a circle).
[F12]

Draws an ellipse. [F11]

Drawing by hand. [F1]

Draws a straight line. [F2]

Draws a polyline. [F5]

The Auto Detect filled tool. Detect hollows using threshold techniques. Click to the image to
place the probe, the detected area is drawn. You can adjust the thresholding range by using 
the mouse wheel or by pressing the +, - keys. [Ctrl+B]

Threshold tool. Click into the image to place the probe (or more of them) to define the initial
color level for thresholding. Pres +,- keys or use the mouse wheel to change the 
thresholding range. [J]

Fill an enclosed shape. [F6]

Area of interest. All objects outside the selected region will be erased.

Text tool. Displays dialog box for defining text parameters.

[Commands] tool. Displays a pop up menu offering user some additional commands:

Commands

The Auto Detect hollow tool. Detect hollows using threshold techniques. Click to the image
to place the probe, the hollow is drawn. You can adjust the thresholding range by using the 
mouse button or by pressing the +, - keys.

Draws rectangularly crossed lines.

Draws a rose. Click to the image to define the center, than drag the mouse to set the length
of it's arms.

Places a marker to the image. Simply click into image...

Selects binary objects.
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The Connect tool. Draws a line(s) from the place you've clicked to the nearest object(s).

Displays a grid. Visible only when using magnification 400% and higher.

Hides the binary image and displays the just the color image.

Inverts the binary image. Foreground becomes background and vice versa.

The last two buttons perform simplified versions of mathematical morphology functions. Please
see the Mathematical Morphology Basics  chapter for more details.

Smooth

Contour

Tools are either applied in a "draw" (foreground) or "erase" (background) mode.
Some tools (like threshold or bezier) have editable parameters. Tips how to use the tools are
displayed in the vertical toolbar.

Multiple Binary Layers

An arbitrary number of binary layers can be created within one document. Click this [Create
New Binary Layer] button to add a new binary layer. The binary layer that you are currently
editing can be selected in the nearby pull-down menu. Binary layers can be managed from
the [View > Visualization Controls > Binary Layers] control window.
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Measurement

Measurement is an advanced and complex image analysis technique. It starts with calibration of
the NIS-Elements system and finishes with a quantitative evaluation of the image.

Calibration

Calibration is of crucial importance to measurement. A calibration assigns real size to one pixel,
so that correct and realistic measurements can be performed and the objects of different images
could be compared to each other. A correct calibration has to be made before measurement
begins. See the Configuring Attached Hardware  chapter which explains how to calibrate the
NIS-Elements system.

Rough Measurement

Quick and approximate measurements can be performed utilizing graticules. They behave like
adjustable floating rulers. User can simply align a graticule with the measured object and read
the distance value (e.g. the diameter). To activate the graticule, press the [Graticules] button
placed in the top-right corner of the document window.

Select Graticule Type

The type of the graticule ruler is indicated by a picture on the [Graticules] button. To change the
graticule type, click on the graticules button with the right mouse button and select the
appropriate item from the context menu:

Rectangular Grid
Circle
Simple Circle
Cross
Industrial Cross
Simple Cross
Vertical Ruler
Horizontal Ruler
Graticule Mask

Define Graticule Properties

Right click the [Graticules] button and select the [Graticules properties] command from the
pull-down menu. A dialog window appears where display parameters of all graticules (shape,
color, line width, density of lines) can be adjusted.

Density

The density value - the closest distance between two line intersections of the graticule - can be
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set, or you can let NIS-Elements adjust it automatically according to the current zoom factor. The
units selection depends on the image calibration (calibrated/uncalibrated).

Measure the Image

The graticule measurement offers the following options:

The graticule can be moved by mouse arbitrary.
The graticule position can be reset by using the [Move Graticules to Center] command from 
the context menu.
A binary layer can be created from the current graticule using the [Graticules -> Binary] 
command.
A [Graticule Mask] can be created from the current binary layer using the [Binary -> 
Graticules] command.
A [Graticule Mask] can be stored/loaded to/from an external file via the [Save Graticule 
Mask As] and [Open Graticule Mask] commands. 
A new image containing graticules can be created by the [Edit > Create Full View Snapshot] 
command.

Manual Measurement

Length, area, angles, taxonomy,
counts, circle radius, and ellipse
semiaxes can be measured manually
over an image. The results are being
recorded to a simple statistics table,
which can be exported to a file or
clipboard. Also, the data can be
presented as a graph.

Run the [View > Analysis 
Controls > Annotations and 
Measurements] command. The 
manual measurement control 
window appears.
Select a tool corresponding to 
the feature you are going to 
measure. There are several 
tools for measuring each 
feature.
Measure the objects in the 
image using mouse.
Select where to export results in 
the [Export] pull-down menu.
Export the results using the 
[Export] button.
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Example:

Measurement of a crystal: Select the Horizontal parallel
lines tool. Place the first line on the top adge of the crystal
by clicking into the image. The position of the line can be
adjusted while you hold the left mouse button down. After
you release it, the line is positioned. Repeat this to place
the second line on the bottom edge of the crystal. When
finished, an arrow is drawn between the lines, and the
result of the measurement is attached. A record with the
measurement type and measured value is added to the
results table.

Please see more about manual measurement tools in the Command Reference of the help.

Automated Measurement

Automated measurement is the very powerful of image analysis features. In combination with
user macros, NIS-Elements can become semi- or fully-automatic image analysis tool. There are
several key procedures which a proper automated measurement should involve:

Optical system calibration. Please see the [Optical Configurations] chapter for more details.
Image capture. Please see the [Capturing Images] chapter for more details.
Defining threshold, creating the binary layer. Please see the [Thresholding] chapter for more
details.
Performing the automated measurement.
Results presentation.

Image Layers Involved in Measurement.

Automated measurements are performed on the two image layers:

Binary layer  - is typically used for shape and size measurements (area, perimeter, 
surface fraction).
Color layer  - intensity or hue measurements are carried out on the color layer. The area 

covered with the binary layer is used as the source data.

Object/Field Measurement

Generally, NIS-Elements distinguishes two types of automated measurements: object and field.

Object measurement

Groups of neighbouring pixels of the binary layer are called objects. Object measurements
provide user with specific object data such as Length, Area, CentreX/Y (the X,Y position of the
central pixel of an object), etc.
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Field Measurement

Field measurements produce information regarding the whole measurement frame area such as
Area Fraction, Mean Brightness, Density Variation, etc.

Please see the complete list of measurement features in the [ Measurement Features ] chapter.

Restricting the Area of Measurement

The area of measurement can be restricted by the measurement frame or by a user defined
region of interest (ROI).

Region of Interest

ROI is a user defined area of the image. It can be modified using the commands of the pull-down
menu which appears when you right-click the [Turn Measurement ROI On/Off] button in the
top-right corner of the document window tool bar. Or, it can be edited in the [Measure > ROI
Editor]. Turn the ROI ON via the [Measure > Use ROI] command.

Measurement Frame

The measurement frame is a resizeable rectangular frame which serves for delimiting the
accepted area for measurement. Turn the measurement frame ON via the [Measure > Use
Measurement Frame] command.

The binary objects which touch edges of ROI or the measurement frame can be treated
differently (excluded from the measurement or included). This behaviour can be specified within
the [Edit > General Options > Measurement] dialog window.

Statistics and Data Presentation

NIS-Elements calculates basic statistics - mean value, standard deviation and distribution of all
measured features. The features to be measured can be selected in the [Measure >Object
Features] and the [Measure > Field & ROI Features] dialog windows. Results of all automated
measurements are presented and can be exported from the [View > Analysis Controls >
Automated Measurement Results] control window.
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Measurement Features

The following list describes all the features that can be measured within NIS-Elements
Measurements. Suitable type of measurement (object/field/interactive) and the required image
layer (binary, color/binary) are included in the description.

 

a

a - coordinate in the CIE-LAB color system

Measurement Type object, field

Image Type color

 

AcqTime

Calling the Grab Sequence command, the AcqTime is set to zero at the beginning. Then,
NIS-Elements assigns the AcqTime to every newly grabbed image file header, which denotes time
elapsed from the beginning of the grabbing. If the Grab Sequence command is not called, than
the AcqTime is the time elapsed since the start of NIS-Elements.

Measurement Type object, field

Image Type binary

 

Area

Area is a principal size criterion. In a non-calibrated system, it expresses the number of pixels; in
a calibrated one, it expresses the real area.

Measurement Type object, field, 
interactive

Image Type binary
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AreaFraction

AreaFraction is the ratio of the segmented image area and the MeasuredArea. It has a strong
stereological interpretation: in the case of isotropic uniform random sections it is equal to the
volume fraction.

AreaFraction = Area/MeasuredArea

Measurement Type field

Image Type binary

 

b

b - coordinate in the CIE-LAB color system

Measurement Type object, field, 
interactive

Image Type color

 

Blue

Blue value is the the mean of blue component pixel values. It is the usual statistical mean of
intensity values of the blue component.

Measurement Type interactive

Image Type color

 

BoundsLeft, BoundsRight, BoundsTop, BoundsBottom

Theses are distances (X or Y coordinates) of the left, right, top, and bottom edge of the object
bounding rectangle. The units of calibration are used if the image is calibrated. Otherwise, the
coordinate value is in pixels.

Measurement Type object

Image Type binary
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BoundsAbsLeft, BoundsAbsRight, BoundsAbsTop, BoundsAbsBottom

These are absolute distances (X or Y coordinates) of the left, right, top, and bottom edge of the
object bounding rectangle within a motorized stage range. This feature can be measured only
when the motorized stage is connected.

Measurement Type object

Image Type binary

 

BoundsPxLeft, BoundsPxRight, BoundsPxTop, BoundsPxBottom

These are distances (X or Y coordinates) of the left, right, top, and bottom edge of the object
bounding rectangle. Unlike the BoundsLeft,... distance, this value is always in pixels.

Measurement Type object

Image Type binary

 

BrightVariation

The BrightVariation is derived from brightness values. It is the usual standard deviation of
brightness values. It is calibration dependent. For more details about bright variation see also the
Densitometric and brightness measurements section in the Measurement chapter.

Measurement Type object, field

Image Type color/binary

 

CentreX

CentreX is the x co-ordinate of the center of gravity. The units of calibration are used if the image
is calibrated. Otherwise, the coordinate value is in pixels.

Measurement Type object

Image Type binary
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CentreY

CentreY is the y co-ordinate of the center of gravity. The units of calibration are used if the image
is calibrated. Otherwise, the coordinate value is in pixels.

Measurement Type object

Image Type binary

 

CentreXabs

CentreXabs is the absolute x co-ordinate of the center of gravity within a motorized stage range.
This feature can be measured only when the motorized stage is connected.

Measurement Type object

Image Type binary

 

CentreYabs

CentreXabs is the absolute y co-ordinate of the center of gravity within a motorized stage range.
This feature can be measured only when the motorized stage is connected.

Measurement Type object

Image Type binary

 

CentreXpx

CentreXpx is the x co-ordinate of the center of gravity. Unlike the CentreX coordinate, this value
is always in pixels.

Measurement Type object

Image Type binary
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CentreYpx

CentreYpx is the y co-ordinate of the center of gravity. Unlike the CentreX coordinate, this value
is always in pixels.

Measurement Type object

Image Type binary

 

Circularity

Circularity equals to 1 only for circles; all other shapes are characterized by circularity smaller
than 1. It is a derived shape measure, calculated from the area and perimeter. This feature is
useful for examining shape characteristics.

Circularity = 4*π*Area/Perimeter2

Measurement Type object

Image Type binary

 

Class

NIS-Elements recognizes 12 classes (1-12). If you have selected class feature (function Object
Features or Field Features), system automatically asks you to specify the class via dialog box. In
field or scan objects measurements, the application asks for a class before measurement is
performed on the current image. In single object measurement, NIS-Elements asks for a class for
every measured object. In the case you want to pass by, there is a possibility to run the
SetClass  function.

Measurement Type object, field, 
interactive

Image Type binary
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DensityVariation

DensityVariation is derived from density values. It is a usual standard deviation of density values.
For more details about density features see also the Densitometric and brightness measurements
section of the Measurement chapter.

Measurement Type object, field

Image Type color/binary

 

Elongation

Elongation is determined as a ratio of MaxFeret and MinFeret features. This feature is useful for
shape characteristics.

Elongation = MaxFeret/MinFeret

Measurement Type object

Image Type binary

 

EqDiameter

The equivalent diameter is a size feature derived from the area. It determines the diameter of a
circle with the same area as the measured object:

Eqdia = sqrt(4*Area/π)

Measurement Type object, interactive

Image Type binary

 

ExPurity

This feature specifies the amount of white in the measured color, if the measured color can be
composed of white and a pure spectral color (see below).

Measurement Type object, field, 
interactive

Image Type color
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FillArea

In case an object does not contain holes then the FillArea is equivalent to the Area. If an object
contains holes, FillArea remains the same while Area is reduced by the area of the holes.

Measurement Type object

Image Type binary

 

FillRatio

FillRatio is the ratio of Area and FillArea:

FillRatio = Area/FillArea

If an object does not contain holes the FillRatio is equal 1. If an object contains holes, FillRatio is
less than 1. This feature can distinguish objects with and without holes.

Measurement Type object

Image Type binary

 

IntensityVariation

IntensityVariation is derived from an intensity histogram. It is an usual standard deviation of
intensity values. This feature describes the inner structure of an object or a field.

Measurement Type object, field

Image Type color

 

Green

Green value is the mean of green component pixel values. It is the usual statistical mean of
intensity values of green component.

Measurement Type interactive

Image Type color
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HueTypical

HueTypical is the hue value with maximum frequency in a
hue value histogram. This feature describes the most
frequent hue (color) in an object or field.

Measurement Type object, field

Image Type color/binary

 

HueVariation

HueVariation is the usual standard deviation of hue values.
This feature describes hue (color) distribution of inner
structure of an object or field.

Measurement Type object, field

Image Type color/binary

 

SumBrightness

Sum Brightness is defined as the sum of brightness in every pixel of the object.

Measurement Type object, interactive

Image Type color/gray
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SumDensity

SumDensity is the sum of individual optical densities (O.D.) of each pixel in the area being
measured. This feature describes, for instance, the amount of a substance in biological sections.
Optical density is evaluated according to the following formula:

O.D. = -log((PixelIntensityValue + 0.5)/62.5)

Measurement Type object, field, 
interactive

Image Type color/binary

 

SumIntensity

Sum Intensity is defined as the sum of intensity in every pixel of the object.

Measurement Type object

Image Type color/gray

 

L

L - coordinate in the CIE-LAB color system

Measurement Type object, field, 
interactive

Image Type color

 

Length

Length is a derived feature appropriate for elongated or thin
structures. As based on the rod model, it is useful for calculating
length of medial axis of thin rods.

Length = (Perimeter + sqrt(Perimeter2 - 16*Area))/4

Measurement Type object, interactive

Image Type binary
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LineLength

Line length is defined as the length of the object with elongated shape.

Measurement Type object

Image Type color/gray

 

Luminance

Luminance is defined as a radiant power weighted by a spectral sensitivity that has characteristics
of human vision.

Measurement Type object, field, 
interactive

Image Type color

 

MaxFeret

The MaxFeret is the maximal value of the set of Feret's diameters. Generally (for convex objects),
Feret's diameter at angle α equals the projected length of object at angle α, α ∈(0,180);
NIS-Elements calculates Feret"s diameter for α=0, 10, 20, 30, ... , 180.

Measurement Type object, interactive

Image Type binary

 

MaxFeret90

The MaxFeret90 is a length projected across the MaxFeret
diameter.

Measurement Type object, interactive

Image Type binary
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MaxIntensity

MaxIntensity value is derived from the intensity histogram. It is the maximal of intensity pixel
values.

Measurement Type interactive

Image Type color/gray

 

MeanBlue

MeanBlue value is the mean of blue component pixel values. It is the usual statistical mean of
intensity values of blue component.

Measurement Type object, field, 
interactive

Image Type color/binary

 

MeanBrightness

MeanBrightness value is the usual statistical mean of brightness values of pixels. NIS-Elements
uses brightness calibration curve for evaluation of this parameter.

Measurement Type object, field, 
interactive

Image Type color/binary

 

MeanDensity

MeanDensity value is the usual statistical mean of density values of pixels. NIS-Elements uses
density calibration curve for evaluation of this parameter.

Measurement Type object, field, 
interactive

Image Type color/binary
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MeanIntensity

MeanIntensity value is derived from the intensity histogram. It is the usual statistical mean of
intensity values of pixels.

Measurement Type object, field, 
interactive

Image Type color/binary

 

MeanGreen

MeanGreen value is the mean of green component pixel values. It is the usual statistical mean of
intensity values of green component.

Measurement Type object, field, 
interactive

Image Type color/binary

 

MeanChord

MeanChord is the mean value of secants in the 0, 45, 90 and 135 degrees directions. It is a
derived feature and is calculated from the Area and mean projection according to the following
formula.

MeanChord = 4*Area/(Pr0+Pr45+Pr90+Pr135)

Measurement Type object, field

Image Type binary

 

MeanRed

MeanRed value is the mean of Red component pixel values. It is the usual statistical mean of
intensity values of red component.

Measurement Type object, field, 
interactive

Image Type color/binary
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MeanSaturation

MeanSaturation is a statistical mean of saturation values of
pixels.

Measurement Type object, field

Image Type color/binary

 

MeasuredArea

MeasuredArea value is the area of the measurement frame or of a mask within the measurement
frame, if the mask status is on.

Measurement Type object, field

Image Type binary

 

MinFeret

The MinFeret value is the minimal value of the set of Feret's diameters. Generally (for convex
objects), Feret's diameter at angle α equals the projected length of object at angle α, α ∈(0,180);
NIS-Elements calculates Feret"s diameter for α=0,10,20, 30, ... , 180.

Measurement Type object, interactive

Image Type binary

 

MinIntensity

MinIntensity value is derived from the intensity histogram. It is the minimum of intensity values
of pixels.

Measurement Type interactive

Image Type color/gray
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NumberObjects

NumberObjects value returns the number of objects in the measurement frame. Exclusion rules
for counting objects are taken into account.

Measurement Type field

Image Type binary

 

Orientation

Orientation is the angle at which Feret's diameters have their maximum. The diameters are
calculated with 5 degrees angle increment.

Measurement Type object

Image Type binary

 

Perimeter

Perimeter is the total boundary measure. It includes both the outer and inner boundary (if there
are holes inside an object). The perimeter is calculated from four projections in the directions 0,
45, 90 and 135 degrees using Crofton's formula

Perimeter = π*(Pr0+Pr45+Pr90+Pr135)/4

Measurement Type object, field, 
interactive

Image Type binary
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Red

Red is the mean of red component pixel values. It is the usual statistical mean of intensity values
of red component.

Measurement Type interactive

Image Type color

 

StartX

StartX is the x co-ordinate of a pixel on the object boundary.

Measurement Type object

Image Type binary

 

StartY

StartY is the y co-ordinate of a pixel on the object boundary.

Measurement Type object

Image Type binary

 

StgPosX

StgPosX feature is the x co-ordinate of the absolute position of the measured field. It is available
only for systems equipped with a stage.

Measurement Type object, field

Image Type binary



105

 

StgPosY

StgPosY feature is the y co-ordinate of the absolute position of the measured field. It is available
only for systems equipped with a stage.

Measurement Type object, field

Image Type binary

 

SurfVolumeRatio

SurfVolumeRatio is a feature with a strong stereological interpretation: if you measure on fields
that are sampled systematically and independently of the content of the sections, then the
feature is an unbiased estimator of the surface area of objects (inner structure) per volume of the
whole sample.

SurfVolumeRatio = (4/π)*Perimeter/MeasuredArea

Measurement Type field

Image Type binary

 

Time

Time assigns the time to a field (object) after a measurement has been performed. See the
SetReferenceTime  function help.

Measurement Type object, field

Image Type color/binary

 

u

u - coordinate in the CIE-uv color system.

Measurement Type object, field, 
interactive

Image Type color
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v

v - coordinate in the CIE-uv color system.

Measurement Type object, field, 
interactive

Image Type color

 

VolumeEqCylinder

This parameter is based on the rod model. Length is interpreted as height and Width as the base
diameter of a cylinder. Bases are considered to be spherical.

VolumeEqCylinder = (πd2)*(l-d)/4 + πd3/6,

where l=max(MaxFeret, Length), d=min(MinFeret, Width).

Measurement Type object

Image Type binary

 

VolumeEqSphere

Supposing a profile was created as an intersection of a ball and a section that contains the center
of the ball. VolumeEqSphere is the volume of the ball.

VolumeEqSphere = π*Eqdia3/6

Measurement Type object

Image Type binary

 

WaveLen

Dominant wavelength. This feature is defined as a wavelength of the pure spectral color that is,
together with white, the measured color composed of. The color in the purple must be composed
of more than one pure spectral colors therefore they have no dominant wavelength.

Measurement Type object, field, 
interactive

Image Type color
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Width

Width is a derived feature appropriate for elongated or thin
structures. It is based on the rod model and is calculated
according to the following formula:

Width = Area/Length

Measurement Type object

Image Type binary

 

x

x - coordinate in the CIE-xy color system.

Measurement Type object, field, 
interactive

Image Type color

 

y

y - coordinate in the CIE-xy color system.

Measurement Type object, field, 
interactive

Image Type color
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Time Measurement

The time measurement tool enables to record avarage pixel intensities within ROI during a time
interval. The measurement can be performed on Live camera signal. Before the measurement is
started, a region of interest (ROI) shall be defined/enabled. Run the [View > Analysis Controls >
Time Measurement] command to open the Time Measurement control window.

Display the [View > Analysis Controls > Time Measurement] control window.
Enable the Measurement ROI by the [Measure > Use ROI] command. Time measurement 
will be performed under the Measurement ROI area.
Run the [Acquire > Live Fast] command to display the camera signal.
Press the [Measure] button. It changes to [Pause].
Press the [Stop] button to pause/finish the measurement.

If you run an ND2 experiment and the [Run during ND acqisition] button is pressed at the same
time, time measurement will begin automatically right as the experiment starts. The
measurement results can be exported via the [Export] button, please, see the [ Exporting
Results ] chapter.

ROI Definition

To define areas where the measurements will be performed:

Run the [Acquire > Live Fast] command to display the camera signal.
Enable ROI by the [Measure > Use ROI] command.
To modify ROI, right-click the ROI button on the right side of the document window and use 
one of the [Draw...] commands from the context menu. 
Or, use the [Define] button placed in the time measurement window toolbar to display the 
ROI definition bar.
Or, ROI can be modified using the [ Measure > ROI Editor] . When finished, quit the ROI 
editor by the [Tab] key.
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Measurement Options

Click the [Options] button. A dialog appears where you can specify the time measurement
details:

User events

Arbitrary time of some user events can be indicated in the data table or the graph by a marker.

[Define Hot Keys] - Press this button to define up to 4 hot keys. Select a shortcut key 
combination and insert a user text. A marker and the user text will be inserted each time 
the shortcut is used during the time measurement.
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Timing

A time interval shall be set to determine how often one partial measurement will be performed.

The [Measure every N frame] section defines after how many (N) frames one measurement 
is performed.
The [Measure every N ms] section defines directly the time interval in miliseconds.

This setting can be modified during a time measurement process by pressing the [+] and [-]
buttons. These buttons increase/decrease the speed of recording the time measurement data.

Graph & Data

Some of the graph and data table properties can be modified:

Display Properties

The colors and the line widths of the graph can be selected from a pull-down menu.

Vertical/Horizontal axes always visible

If checked, the axes do not leave the graph area while zooming in the graph.

Vertical AutoScale

This option optimizes the displayed graph area. If the measured intensities do not reach
maximum values, the top part of the graph is hidden.

Show grid

The grid in the background may be or may be not displayed by selecting this option.

AntiAlias

Turning this option on will make the graph line edges look smooth.

Display graph points (if possible)

Small dots indicating the actual data values position can be displayed on the graph line. The
points appear only if the distance between them is big enough for them to be recognized (they
usually appear when you zoom in the graph).

Interpolation method

The profile line shape may be smoothed out by using an interpolation method. Select one of the
three available: Quick (basic), Linear (smoother), Bicubic (really smooth).

Data decimals

Select the precision of the results in the data table.
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Multi ROIs, Multi Dyes

The [Multi ROIs] and [Multi Dyes] buttons swap between two measurement modes:

Multi ROIs  - One or more continuous areas can be defined within a measurement ROI. In 
this mode, data for each of the areas are available.
Multi Dyes  - In this mode, data for each color channel (averaged from the whole 

measurement ROI) are available.
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Object Count

If you run the [View > Analysis Controls > Object Count], the following control window appears.It
combines important image analysis tools, which enable users to threshold, measure the image,
and export the measured data to a file in a smooth way. Object count can be performed even on
Live image.

Thresholding the image

Threshold limits have to be defined by choosing reference points in the image. Select one of the
following tools:

1 point threshold tool.

3 points circle threshold too.l

6 points circle threshold tool.

Click inside the image to define typical object areas. The system will detect similar parts of the
image and highlight it by color edges and fill. The threshold limits are indicated in the histogram
and can be further modified by dragging the limit lines by mouse.

Please, refer to the Thresholding  chapter for further details.

Applying measurement restrictions

The number of objects that are included in the results table can be restricted by defining some
limiting features. The objects that do not fit these limits will not be taken into account.

Right click to the restrictions field to select one or more of the following measurement 
features: Area , EqDiameter , Perimeter , Length , Width , MaxFeret , MinFeret ,
Circularity , Elongation , MeanIntensity , SumIntensity
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Select the restriction feature you would like to define.
Move sliders below the histogram to set the limits. The limit values are indicated next to the 
feature name, and can be modified directly by double clicking the indicated value*. 
Decide whether the defined interval will be excluded or included from/in results. This is done
by setting the Inside/Outside  value next to the feature name.
The nearby checkbox indicates whether the restriction is applied or not. If applied, the 
histogram below is color, otherwise it is gray.

* - infinitude can be defined by entering "oo" or "inf".

Reset

The [Reset] button discards restriction settings of all features.

Bins

This is a number of columns in the histogram.

Working with measured data

The following results appears in the results table:

Total Area  is the area of the whole image in px2 or calibration units 2. 
Area Fraction is the ratio between Total Area and the area of the thresholded objects

in %.
Number of objects  counts the thresholded objects.
Table of results  - every thresholded object is measured and the results are inserted to 

this table. Select the columns to display/hide from the context menu that appears when you 
right-click one of the column names.
#  - number of selected objects is displayed in the box next to the buttons. One or more 

objects can be selected by mouse while holding the [Ctrl] or the [Shift] key.

The following tools can be used:

Delete selected objects  removes the selected objects. The objects can be selected by 
mouse holding the Ctrl  key down.

Invert selection  deselects the selected objects and vice versa.

Generate binary  converts the current OC layer to binary layer (the previous binary layer 
is overwritten).

Count objects in ND image  - when an ND2 file is opened, this button can be used. The 
thresholding, measurement, and restrictions is applied to a single frame by default. Pressing
this button to apply it to all frames of the ND2 document and export the results to a file or 
clipboard according to the current export options.
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Save/Load Object Count configuration  invokes a pull-down menu which enables to 
load/save the current object count settings from/to an external file (*.counting).

Keep updating count  refreshes the measured results each time the OC layer changes.

Data Export

The measured data can be exported to clipboard or a file using the [Export] button. Please refer
to the [ Exporting Rresults ] chapter for further details.
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Tracking (AR)

Moving objects (e.g. living cells) captured by time lapse acquisition  can be tracked automatically
or manually using the [Tracking] control window. Various indicators of the object movements
such as current position, velocity, acceleration, etc. can be measured. The output is a table or a
graph. Run the [View > Analysis Controls > Tracking] command to display the control window:
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Automatic Tracking

Define the objects to be tracked. Sometimes, images of the image sequence (ND2 file) may need
to be enhanced, so the differences between objects and the background would become obvious.

One by One Definition

Select the frame from which you would like to track an object. Zoom in the image, click the
[Define New] button, and mark the object by mouse:

Click to the middle of the object and drag the cursor to its edge.
An auto-detection algorithm will determine the object area according to the pixel intensity 
values in the image.
When the red line which indicates the computer-estimated object edges is around the object
edges, release the mouse button.
Define as many objects as you would like to, then click the [Finish] button.

Overall Definition

Select the [Define All] button. The definition method is the same as described above, except
that the auto-detection algorithm tries to detect all objects in the image similar to the one
you are just defining. Therefore it is enough to define one object only.

Tracking

If you finished defining objects, run the automatic tracking procedure:

Select the first frame of the image sequence.
Press the [Track Automatically] button.
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Tracking Options

Click the [Settings] button, the following options dialog window appears. Select the
[Detection] tab.

Predicted movement

The tracking algorithm can be optimized for a certain type of movement. In the left half of the
window, select whether the objects are moving directly, randomly, or moving in circles, changing
size and intensity, or not. These settings may be assigned to a single object or to all of them -
select the object (Object1, Object2, ..., All) from the bottom pull-down menu.

Auto Path Detection

If you redefined or edited an object, only the frames that you were working with are actually
affected. However, you can apply the performed changes to all subsequent frames by turning the
[Auto Path Detection] option ON. The workflow should look like this:

Turn the [Auto Path Detection] ON.
Edit an object in one of the above described ways.
The trace from the edited frame to the end is re-traced automatically.

Capture setting

The tracking does not need to be performed on every frame of the image sequence e.g. if the
objects move very slowly, or for other reasons. Select the tracking frequency on the right side of
the dialog window and select which color channels will the measurement be performed on from
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the bottom pull-down menu. A single channel or [All] channels are the options.

Track disappearing objects

Objects may disappear or seem to disappear from the image during the acquisition. This option
tells the system to try to find the trail of such lost objects. If this option is disabled, the object
track will be finished where the object has been last detected.

Manual Tracking

Define the objects to be tracked (follow the procedure described in the Automatic Tracking 
portion of this chapter). Lets assume that you have a 10-frames image sequence and you 
defined objects [1], [2], and [3] to be tracked.
Press the [Track manually] button.
The objects [2] and [3] disappear momentarily, and the 2nd image from the image 
sequence is displayed automatically. The position of object [1] in the 1st image frame is 
indicated with white color. You are about to define its position in the 2nd frame.
Click to the center of the object to define the position of it in the frame 2.
Object [2] appears highlighted in white. Define its position in the 2nd frame by another 
click.
This way you define the 2nd trajectory point of object [3], too. 
Then, the 3rd image frame of the sequence is displayed waiting for the third trajectory point
of object [1] to be defined, etc.

Object Redefinition

Some objects, especially if they are living cells, can change their characteristics - fade, change
size, etc - during the movement. In such cases, the automatic tracking algorithm may get
"confused" and loose the track for a while. This can be manually corrected by the following tools:

Redefine

When an object changes its characteristics so that the system becomes unable to track it
properly, use the [Redefine] button:

Select the frame of the sequence where the tracking algorithm got lost for the first time.
Select the object in the [Objects] table next to the graph.
Click the [Redefine] button and define the object (the object definition is described above).
Features such as area and intensity characteristic of the object change when redefined.

Edit Objects

The editing mode works similarly as when redefining an object, but does not change the object
characteristics, only the trajectory is changed.

Switch to the editing mode by pressing the [Edit Objects] button and display object traces 
by the [Show Trace] button.
Click the point you would like to modify and drag it by mouse to the right position.
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Visualization

The following tools help to visualize the tracking process:

Overlay

You might want to see the whole image sequence in one image. The [Overlay] button can display
an additional layer over the current image. To adjust its properties, invoke the [Settings] button
and select the [Overlay] tab in the dialog window. Three types of overlay image can be selected:

[Maximum Intensity Projection] - pixel values with the same XY coordinates are compared 
throughout the image sequence and only the pixels with the highest intensity value are 
displayed in the layer. 
[Minimum Intensity Projection] - pixel values with the minimum intensities of the whole 
image sequence are displayed in the image.
[Sequence Intensity Projection] - this is a special overlay, which dyes the trajectories by a 
color scale (blue-red). The movement direction and the object velocity become obvious.

[Color] and [Transparency] of the layer can be adjusted as well.

Show Trace

Press the [Show Trace] command from the [Settings] pull-down menu to display colored 
trajectories of all tracked objects in the document. The color can be changed within the table
of objects.
Select to [Show Points/Show Names] from the same pull-down menu. Positions of the 
objects in each measured frame will be indicated by a cross and a numbered name (Object1,
...).

Click the [Settings] button and select the [Trace] tab to adjust the trace properties:

Line Properties

Select one of the radio buttons which offers to "paint" the trace 1/  [by objects] - each object
trace has different color; 2/  [by velocity/time] - a random color gradient may be defined in
order to indicate the object velocity or the time of its occurence at a certain place.

Tail Properties

If the [Show tails] option is checked, colored tails appear in the image following each of the
traced objects. The length of a tail indicates the current object velocity. Number of segments that
the tail is composed from and the tail start width can be adjusted here.

Cross Properties

The cross appearance (height and line width) of the [Show Points] markers is adjustable here.
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Kymograph

A kymograph gives a graphical representation of spatial position over time. In NIS-Elements, it
displays pixel intensities changes under a defined linear section over time. A trajectory of a
tracked object, or a user-drawn line can be used as the kymograph line.

Create Kymograph by Line

Select the [Create Kymograph by Line] command from the [Kymograph] pull-down menu. 
The mouse cursor changes.
Draw a line in the image. Finilize it with right-click.
A new document called "Kymograph" is created.

Create Kymograph on Selected Object

Select one of the objects in the objects table the trajectory of which you want to use for the 
kymograph line.
Select the [Create Kymograph on Selected Objects] command from the [Kymograph] 
pull-down menu. 
A new document called "Kymograph" is created.

Measurement

A data set of object features is gathered during the tracking procedure. Common features such as
object area or object position are measured as well as movement-descriptive features such as
acceleration and velocity. Their complete list is to be found in the [Settings] dialog box. To
display it, click the [Settings] button and switch to the [Measure] tab. The check boxes indicate
features that are going to be included in the [Data] table. Display the [Data] table by clicking the
tab at the bottom of the control window (next to the [Graph] tab).

Define Reference Point

There are three movement-descriptive features which can be measured in relation to a reference
point (if it has been defined). These are the Reference Length, Reference Velocity, Reference
Acceleration. If an object was moving in circles around the reference point, the features will be
constant/zero.

Click the [Define] button. The dialog window disappears.
Place the Reference point to the image by mouse. The dialog window reappears.

Export

The measured data or the graph can be exported to an external file using the [Export] button.
Please refer to the Exporting Results  chapter for further details.
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Graph Properties

The appearance and behaviour of the graph can be modified in the [General Graph Properties]
dialog window. Right-click inside the graph area and select the [Options] command from the
context menu.

First/Second Line Properties

These settings (line width and style) are applied to the velocity and acceleration graph lines. The
[Color Highlighting] option ensures that the two lines will differ in color.

Vertical/Horizontal axes always visible

If checked, the axes do not leave the graph area while zooming in the graph.

Show grid

The grid in the background may be or may be not displayed by selecting this option.

AntiAlias

Turning this option on will make the graph line edges look smooth.

Display graph points (if possible)

Small dots indicating the actual data values position can be displayed on the graph line. The
points appear only if the distance between them is big enough for them to be recognized (they
usually appear when you zoom in the graph).
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Interpolation method

The profile line shape may be smoothed out by using an interpolation method. Select one of the
three available: Quick (basic), Linear (smoother), Bicubic (really smooth).
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Mathematical Morphology Basics

The binary image as a result of thresholding often needs to be modified before any
measurements are performed. Edges of the objects can be smoothed, holes in the objects filled
etc. by using the mathematical morphology commands. "Image Analysis and Mathematical
Morphology" by J. Serra (Academic Press, London, 1982) was used as a reference publication for
the following overview.

The basic processes of mathematical morphology are: erosion, dilation, open, close and
homotopic transformations.

Erosion  - After performing erosion, the objects shrink. Marginal pixels of the objects are 
subtracted. If an object or a narrow shape is thinner than the border to be subtracted, they 
disappear from the image.

Dilation  - After performing dilation, the objects enlarge. Pixels are added around the
objects. If the distance between two objects is shorter than the thickness of two borders to 
be added, these objects merge together. If a hole is smaller than the thickness of two 
borders, it disappears from the image.

Open  - Open is erosion followed by dilation so the size of the objects is not significantly 
affected. Contours are smoothed, small objects are suppressed and gently connected, 
particles are disconnected.

Close  - Close is dilation followed by erosion so the size of objects is not significantly
affected. Contours are smoothed, small holes and small depressions are suppressed. Closely 
neigbouring objects may be connected together.

Homotopic transformations

Transformations that preserve topological relations between objects and holes i.nside them Using
a homotopic transformation, an object with 5 holes will be transformed to another object with 5
holes. Two objects without any holes will become also two objects without holes, but likely with a
different shape and size. Opening, Closing, Erosion and Dilation are not homotopic
transformations. Typical homotopic transformations in NIS-Elements are: Skeletonize, Homotopic
Marking and Thickening.

There are other very important transformations of binary images implemented in NIS-Elements
binary editor:

Clean  - This transformation is also called geodesic opening. The image is eroded first so
small objects disappear. Then, the remaining eroded objects are reconstructed to their 
original size and shape. The advantage of this algorithm is that small objects disappear but 
the rest of the image is not affected.

Fill Holes  - Fills the holes inside objects. This transformation is handy when objects have a
rich inner structure with intensities typical for background. Then, only boundaries are 
detected correctly, but after applying the [Fill Holes] transrormation, objects become 
homogenous. 

Contour  - This transformation converts an object into its contours.

Smooth  - Smooth transformation affects sharp edges of the objects and smooths them.
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Morpho separate objects  This transformation detects standalone objects that are
connected together and detaches them.

Note:

Applying the above mentioned transformations in computerized image analysis brings some
limitations due to digitization. In digitized images, information is known only at grid verticals, and
only a limiting cut-out of the real scene is available. This is the reason why the most frequent
terms in binary image processing are: structuring elements, connectivity, grids, problem with
border areas.

When speaking about binary image processing, a binary image is considered as a set of pixels
where values 1 represent objects (white areas) and values 0 represent background (black areas).
The NIS-Elements system uses a square grid. In this type of grid two possible connectivities can
be used, the 8-connectivity and the 4-connectivity. The difference between the 8 and 4
connectivities is shown in the example picture. If the 8-connectivity is considered, the two pixels
represent one object. If the 4-connectivity is considered, there are two single point objects in the
picture. NIS-Elements works with the 8-connectivity model, so all points neighboring by the
corner belong to one object.

Implementation in NIS-Elements

Erosion, dilation, opening and closing are defined by kernel(matrix/structuring element) and
number of iterations. There are the following kernels used in NIS-Elements:

The bright pixel in the center or near the center of the kernel represents its midpoint.

Erosion

Lets assume the 1 and 0 values represent object(1) and background(0) pixels. You can imagine
an erosion by a kernel as the following algorithm:

Move the midpoint of the kernel to every point of the image. Each time, look at the neighborhood
and make the following decision:

If there are object(1) pixels in all the positions of the kernel, set the midpoint to object(1).
If there is at least one background(0) pixel in the neighborhood, set the midpoint to 
background(0).

The second parameter, the Number of iterations defines how many times the erosion is to be
applied.
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Dilation

You can imagine a dilation by a kernel as the following algorithm:

Move the midpoint of the kernel to every point of the image. Each time, look at the neighborhood
and make the following decision:

If there is at least one object(1) pixel in any position of the kernel, set the midpoint to 
object(1).
If there are background(0) pixels in all the positions of the kernel, set the midpoint to 
background(0).

Open and Close

Open is performed by eroding the image and then applying a dilation to the eroded image. On
the contrary, Closing is performed as a dilation followed by erosion.

Note:

If the midpoint is not in the center, applying erosions or dilations by odd number of iterations
causes image to shift by 1 pixel. Normally, the total image shift would be determined by the
Number of Iterations (in pixels). NIS-Elements eliminates this shift: it changes the position of the
midpoint 1 pixel down-rightwards within the kernel for even operations. For opening and closing it
is possible to eliminate this shift totally. However, if you run the erode or dilate processes again
and again using the kernel with even dimensions and odd number of iterations, then the shift
becomes significant.

Examples

Original image Threshold();
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CloseHoles(); SmoothBinary();

CleanBinary(2,4); OpenBinary(1,4); CloseBinary(1,4);
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OpenBinary(2,4); MorphoSeparateObjects(4,1);

Source Skeleton
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Source Pruning 3-times

Source Pruning 2-times
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Source Convex Hull

Source Contour
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Source Distance Function

Source Ultimate Erosion
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Source Zones of Influence + Source

Source Homotopic Marking
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Source Thickening 9-times
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User Macros

A macro - an executable sequence of commands - can make the work very effective.
NIS-Elements provides a C-like programming language utilizing its internal set of commands. The
sequence of commands can be created either by recording the performed actions, by writing the
commands inside the macro editor, or by modifying the command history (the history is recorded
automatically during the work). The created macro can be saved to an external (*.mac) file for
later use.

Recording a Macro

The fastest way to create a macro is to record it.

Start the NIS-Elements macro recorder by selecting the [Macro > Record] command.
Perform the series of actions you would like to record.
Finish the macro creation by the [Macro > Stop Recorder] command.
It is recommended to check the macro in the macro editor before saving. Run the [Macro > 
Edit] command to display it.
Save the macro to a file via the [Macro > Save As] command.

Writing/Editing a Macro

A macro can be written by hand in the built-in macro editor. Run the [Macro > Edit] command to
display it.

The macro editor provides:

Direct output to a printer.
Undo/Redo functionality.
Command insertion from the 
list of available commands.
Interactive command names 
list. Press [Ctrl+Space] to 
display a simplified list of all 
commands while typing the 
macro.
Syntax hints appear as you 
type a command name. 
Parameter types and names 
appear.
Bookmarks can be placed to the code so you can easily roll to the important parts of the 
macro.
Breakpoints can be placed to the code. A breakpoint forces the macro to stop the execution 
at a certain point so you can check variables state, and inspect the macro "per partes".
Syntax highlighting.
Help on commands with detailed description.
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Creating a Macro from History

You can create a macro using the list of recently performed commands. Run the [Macro >
History] command to display the list and push the [Create Macro] button. The "Create Macro"
wizard appears. You can also call this wizard from within the macro editor by pushing the [Insert
Commands from History] button.

1. Creating Macro - Select Commands

Pick single commands holding the [Ctrl]
key, or select a range holding the [Shift]
key down. The selected commands will be
used in the macro.

[History] - number of commands
performed in the current NIS-Elements
session.
[Currently] - number of currently
selected commands.

2. Creating Macro - Remove Redundant Commands

[Remove redundant commands] - the
sequence of commands that make no image
changes is automatically removed. Usually, it
concerns commands that toggles the image
between two states and were used several
times in a row. It can be for example the
ShowAnnotations(), ShowProbe(), or
EnableLUTs() command. No functionality is
lost when only the last command is kept.
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3. Creating Macro - Edit Single Command

Reverses changes that you made
within this dialog window such as 
cutting, copying, pasting or inserting 
commands.

Removes the selected command(s)
and copies it to clipboard. 

Copies the selected command(s) to
clipboard.

Inserts the command(s) from
clipboard before the currently selected 
command.

Opens the list of commands and
enables you to edit the parameters of 
the selected command (or even 
change the command).

Inserts a command from the list of all commands. Select the command you want to paste
and press the [OK] button.

Inserts a special command. The dialog window that appears includes the most frequently
performed actions, such as Run Macro from File, Pause Macro, etc. Select the action you 
would like to insert and press the [Insert] button.

Displays the help page of the selected command.

4. Creating Macro - Saving As Macro

The last window of the wizard is a standard [Save As] dialog window. Select the destination folder
and the macro name and confirm it by the [OK] button. Or, the macro can be saved as [Untitled]
which is NIS-Elements default macro (it is always loaded in the list of macros). Press the
[Untitled] button (the [File Name] path is filled automatically) and the [OK] button.

Saving a Macro

When you create a macro by recording, you can save it using the [Save or the Save As item in
the Macro menu. To save a macro during editing it, press the Save button in the macro editor.

Running a Macro

NIS-Elements provides several ways to run a macro.

You can run the current macro loaded to NIS-Elements by choosing the [Macro > Run] 
command or by pressing [F4].
You can run a macro that is opened by the [Macro > Open] command by pressing [F4].
You can run a macro directly by pressing a special [hotkey] combination (Ctrl+Alt+1,2,3 ... 
9) that you have assigned to it in the [Macro > Options] dialog window.
You can run a macro at the beginning of the NIS-Elements session, by assigning the
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[StartUp] flag to the macro int the the [Macro > Options] dialog window.
You can run a macro directly by using the [Macro > Run From] command.
You can run a macro by clicking a tool bar button that you have assigned to it by the [View 
> Customize Toolbar > Setup] command.

Breaking a Macro

The macro execution can be stopped by pressing the [Ctrl+Break] key shortcut.
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Creating Reports

Report Generator enables a user to create customized reports containing images, measured data,
user texts, graphics, or database entries. PDF files can be created directly from NIS-Elements.
When you invoke the [File > Report > New Blank Report] command, an empty Report Generator
appears. It provides the following tools:

Draw line...

Draw rectangle...

Draw ellipse...

Draw Arrow...

Insert text field...

Insert image from file...

Insert Table

Insert graph

Aligns the selected objects to the position 
idicated by the line (left)

Aligns the selected objects to center

Distributes the objects regularly in specified direction

Determines whether to apply the align commands relatively to the whole page or to selected
objects

Context menu

Once you insert an object, its appearance, behavior, and position can be changed via the context
menu which appears on right-click:

The [Align or Distribute] command enables moving objects within the page or align them to 
another object.
The [Resize object] command enables to resize two objects to the same size.
The [Bring to front] command changes the order of overlapping objects and brings the 
current object to front.
The [Send to back] command moves the object to the bottom layer.
The [Lock] command locks the object disabling any further changes to it until it is unlocked.
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The [Properties] command opens a dialog window where object properties such as color, 
background color, border size and color, object size, font, aspect ratio, alignment, and shape
can be adjusted.

Working with Report Objects

When you double-click any of the objects of a report, a dialog window appears where the
properties can be adjusted. Some properties are common for all types of objects, and some are
special.

Common Properties

The precise position can be determined by defining the XY coordinates of the top-left corner 
of the object.
Line and fill colors can be selected in a pull-down menu. 
Line widths can be adjusted within the range of 0,75 to 6,0 pts.
Precise width and height of the objects can be adjusted.
Rotation of some objects can be adjusted. 

Special Object Properties

Ellipse

Minor and major axes lenghts can be modified.

Arrow

The arrow tip shape and size can be be modified.

Text Box

Format of the text can be adjusted like in a standard text editor.
The current date and time can be inserted from a pulldown menu.

Image

A new picture can be loaded to the image frame via the [Load Picture] button.
The current image scale is displayed in the properties dialog window. It shows the current 
scale/original image dimensions ratio (the image must be calibrated to use this feature, e.g. 
scale 1:2 means, that the image will be printed in half of its original size).
A scale bar can be displayed below the image. The position and width of the scale bar can be
defined.

Table

Inner and outer borders can be hidden/displayed arbitrary.
Number of rows/columns can be modified.

Graph

The range of displayed values can be limited by defining the min/max values.
Histogram labels can be edited.
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Aligning Objects

You can align two objects to the same horizontal or vertical level.

Select more objects (e.g. by holding down the CTRL key and clicking with the left mouse 
button).
Right-click one of the selected objects and select the [Align or Distribute > Align ...] 
command from the context menu.
The objects will be aligned as indicated on the command icons.
If the [Relative to Page] option is turned ON, the objects will be aligned to the edges/center 
of the page.

Objects of similar size can be distributed uniformly in the horizontal/vertical direction.

Select three or more objects.
Right click one of the objects and select the [Align or Distribute > Distribute...] command 
from the context menu.
Distances between the objects will be adjusted to equal.
If the [Relative to Page] option is turned ON, the marginal objects will be moved to the 
edges of the page.

Sizes of objects can be unified too.

Select two or more objects.
Right-click the "master" object to the size of which you want to resize the other objects.
Select one of the [Resize Objects] submenu commands.

Dynamic Data

Results of automatic/interactive measurement, graphs, or the current image can be inserted to
reports.

Insert an object which can contain dynamic data (text, picture, table, or graph).
Right-click the object and select [Insert Dynamic Data/Insert Dynamic Picture] from the 
context menu.
A dialog window appears.
Select one of the available sources, and click [Next].
Finish the source definition and click [OK]. The data appear on the report page.

List of available dynamic data sources:

Data inserted by user  (available for: image, text, table) - the system will ask you to type 
a text or browse for an image to insert during the report creation. When creating a dynamic 
object of this type, a query text which will be used to prompt you for the data can be 
defined.
System data  (available for: text, table) - enables you to insert some general data such as

date, the name of the user account currently logged in, the page number, or the page count.
Macro  (available for: text, table) - enables you to insert expressions, values, or results of 

the macro which is running simultaneously.
Measurement  (available for: text, table, graph) - enables you to insert results of 
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automatic/interactive measurement.
Database  (available for: image, text, table) - this data source is displayed only when 

creating a database report template (see below). It enables you to insert a link to any of the
database records. 

The real purpose of the dynamic data turns up when creating reports using report templates:

Working with Report Templates

A report template is a layout of the future report(s) which is ready to be filled with data. The data
can be inserted by the user "on demand" or automatically (dynamic data).

To Create a Report Template

Run the [File > Report > New Template] command. An empty Report Generator appears.
Edit the report template in the same way as a common report. 
Insert the dynamic data where it is appropriate - measurement results to text boxes/tables, 
the current image to the image field, etc.).
Save the report template (*.rtt) via the [File > Save] command.

To Insert Dynamic Data to Report Templates

Insert an object which can contain dynamic data (text, picture, table, or graph) to the 
template.
Right-click the object and select [Data Source] from the context menu.
A dialog window appears.
Click the [Define] button. Another dialog window appears.
Select one of the available sources, and click [Next].
Finish the source definition and click [OK]. The data appear in the template.

To Create a Report from the Template

There are two ways of creating the report.

If a template is opened inside the Report Generator, run the [Report Generator > File > 
Create Report] command. Otherwise, use the [NIS-Elements > File > Report > New Report 
from Template] command to open a template from harddisk.
A report opens and the dynamic data is inserted automatically.
Save the report, print it, or export the page(s) to PDF using the commands from the [File] 
menu.
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Creating Reports from Database

Pictures of a database together with the associated table data, or common images with the
associated [Image Info] can be exported straight to a report.

Switch NIS-Elements to [Organizer] by the [View > Organizer Layout] command.
Select one or more images. These images will be exported to the report.
Click the [Report] button on the main toolbar. The following dialog window appears:

In the [Columns] section, you can select fields, which will be included in the report. If you 
are exporting the images from database, you can select database fields. If you are exporting
images from a directory, this enables you to select the image text description fields (applies 
only to images with text info: JPEG2000, LIM and TIFF).
The [Template] portion of the dialog specifies the report template. If you select the 
[Standard] template, images will be organized in rows and columns. It is possible to set the 
number of columns and rows.
If you select the [Custom] report template, then a user report template (*.rtt) can be 
opened from the disc and used for the report creation. If there is an existing report
template, click on the [Browse] button, otherwise click on the [Create new] button.

After You Pressed the [Create New] Button

A wizard appears. Select number of columns and rows of the new report template. Click 
[Next].
Select the paper size, page orientation, and define margins. Click [OK].
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An untitled report template opens containing a grid spaced according to the [columns/rows] 
settings.
Edit the top-left cell of the grid. You can change the text/image boxes position, size, and 
mapping. During report creation, the other cells of the grid will be filled automatically 
according to the settings of the first one.
A custom header or automatic page numbering can be added to the report.



143

Exporting Results

Some image analysis data and measurement tasks results can be transferred out of
NIS-Elements so they could be used further. This regards for example the intensity profile,
histogram, measurements control windows. There is a standard [Export] pull-down menu in some
of the control windows which enables the export.

The set of commands of the menu differs according to the control window type. Click the [Export]
button to display the pull-down menu. When you select the subject of export and the destination,
the pull down menu hides and the icon corresponding to what you selected appears on the
[Export] button. The export action is performed after the button is pressed once more.
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Export Destinations

It is possible to export tabular data or a graph:

To MS Excel

Tabular data can be exported to MS Excel. A new XLS sheet opens and the table is copied to it
automatically. Sometimes, there is also the [Export (All) To Excel] option, which copies the
tabular data and the graph image into the sheet.

To a File

Data tables can be exported to an external *.txt file, graph images to a *.bmp file. Select the
command from the pull-down menu and define the target file name in a standard Save As dialog
window, which opens. Confirm the export by the [Save] button.

To Clipboard

Data tables and graph images can be exported (copied) to Windows clipboard. Then the data or
the image can be inserted into any appropriate application (text editor, spreadsheet processor,
graphics editor) typically by the [Paste] command.

To Report

Tabular data and graph images can be exported to NIS-Elements report. If a report is already
opened for editing, the data/graph will be appended to it. Otherwise, a new report will be created
and the exported data inserted to it.

To Web Browser, To Clipboard as HTML

Some tabular data can be exported as a HTML table. It can be displayed in a default internet
browser (the [To Web Browser] option), or the HTML code can be copied to Windows clipboard,
ready to be inserted to any HTML editor.
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Tips & Key Shortcuts

Binary Layer Properties

When in overlay mode:

[Insert] switches between predefined overlay colors.
[Ctrl + Up/Down] increases/decreases the binary 
layer transparency.

Single binary objects can be erased in the following way:

Run the [View > Analysis Controls > Binary Toolbar].
Select the [Delete Object] tool from the toolbar.
Click inside the objects to be erased.

Copying Channels by Drag and Drop

Single images

Drag one of the channel tabs and drop it:
To another image, so it will become a multichannel image. 
Inside the NIS-Elements application window in order to create a new document.

Even the [All] and [RGB] tab can be copied.
When extracting a channel from Live image, it does not freeze the camera signal.

ND2 documents

Drag one of the channel tabs and drop it by the [left mouse button]. It behaves the same 
way as if performed on a single image.
Drag one of the channel tabs by the [right mouse button] and drop it to the application 
screen. A context menu appears that enables you to select whether to create the new 
document from all frames or just a single frame. 
[Two ND2 documents] that have matching structure can be [merged into one] easily. E.g. 
two single channel Z stacks with the same number of Z positions can be merged into a 
single two component ND2 Z-stack by dragging one into the other. 
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Drag one of the channel tabs of a [single image] and drop it [to an ND2 document]. The 
channel will be copied to every position of the ND2 file. This behaviour too takes place when 
copying channels that do not have matching structure (just the current frame is copied to 
every position of the target ND2).

Interactive channel selection

Two or more channels can be selected to be viewed:

Click the appropriate channel tabs while holding the [Ctrl] key down.
If some processing is performed, it is applied to the selected channels only.

Shifts on ND2 documents

A single color channel or the whole image (all channels) can be shifted using commands of the
[Image > Shift] submenu. If an ND2 file is opened, the shift can be applied arbitrary to:

the current image frame.
all images of the ND2 document.
a selected dimension of the ND2 document.

The procedure works equally to other image processing performed on ND2 files:

Select the image frame and the channels to be shifted.
Perfom the shift using [Ctrl+Shift+Arrows] key shortcuts.
A standard ND2 image processing dialog window appears.
Select which part of the ND2 document to apply the shift to, and confirm it by [OK].

Live Image, Frozen Image

[+] turns the [Live - Fast] camera mode ON.
[-] freezes the Live image. 
[Ctrl] + [+] turns the [Quality - Capture] camera mode ON.
[Ctrl] + [-] performs image acquisition in the Quality - Capture mode.
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ND2 documents in detail

Make a user selection of the frames by mouse holding [Ctrl] or [Shift] down.
Right-click the navigation bar to invoke the context menu. A selection can be adjusted, 
deleted, or the nd2 file can be cropped.
Detailed info about dimensions will be displayed after you click the leftmost button of the 
navigation tool bar (T>, Z>, MP>).
Place the cursor over the navigation tool bar of one of the dimensions. A tooltip which 
displays statistics of the dimension appears.

LUTs

A context menu can be displayed when right clicking the LUTs graph area. The following options
can be selected:

[Draw trend style] - When ON, the LUTs curves will be smoothed to display the data trends 
rather then represent the actual image data values. 
[Copy LUTs, Paste LUTs] - The current LUTs settings may be copied and inserted to another 
image.

The position of each triangular slider at the bottom of the LUTs window can be reset by double
clicking it. The pixels that reach the maximum value can be highlighted using the LUTs [Color
Overexposed] button.

Modifying Application Appearance

All buttons on main tool bars may be enlarged. Go for [View > Layout > Layout Manager], 
select [Toolbars] in the layout tree, and check the [Large Buttons] option. It affects all 
layouts.
The channel tabs at the bottom of image window may be hidden to save some space of the 
screen. Go for [Edit > General Options > Appearance] and unselect the [Show Channel 
Tabs] option.
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When an image is displayed in great magnification, scroll bars automatically appear by the 
sides of the document window. You can hide them by selecting the [Hide Scroll Bars] 
command from a context menu (right click inside the image).

Restrictions

An easy way to apply restrictions to objects measured via the [Object Count] tool is available:

Open the Object Count  control window, threshold the image to separate objects from 
background. 
Right click the list of restrictions features and pick all features you would like to use.
Select the one restr. feature you would like to set (now) by mouse. Lets assume you have 
selected Circularity.
Right click the thresholded object that is going to be used as a reference one. A context 
menu appears. 
Select whether to include the selected object and all others with higher/lower circularity.
The restriction will be applied and indicated by colors within the image. 

Key Shortcuts

[Z] - It switches to the [Magnifier Glass] tool. When a detail is being observed with Magnifier
Glass and you press the [Z] key again, local contrast enhancement is performed inside the
magnified area. This feature may help to increase the contrast of dark parts of images that are no
more enhanced by the global LUTs settings.

When using the Magnifier Glass tool, pressing the [Ctrl] key switches to pointing tool 
functionality temporarily (so that the image can be dragged by mouse).
If the [Shift] key is pressed while applying the Magnifier Glass, you can move the magnified 
part of the image aside.
When applying the Magnifier Glass to a Z-ND document, pressing the [Ctrl] key changes the 
mouse wheel functionality. The mouse wheel zooms the image instead of browsing through 
the Z-sequence.

[X] - It performs the Create View Snapshot  command. The snapshot includes even the
magnifier glass tool when the X shortcut is pressed while observing a detail.

[`] - Zooms the current image to Fit to Screen mode.

[1] - Zooms the current image to 1:1 mode.

[2] - Zooms the current image to Best Fit mode.

[Up] - Increases zoom of the image.
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[Down] - Decreases zoom of the image.

Context menus

Number of context menus can be displayed by clicking the right mouse button on various items
throughout the application:

Main Status Bar

Layout Tabs  - [Save Current Layout As] and [Layout Manager] commands are available.
Selected camera area  - the [Select Camera] command is available.
Command History area  - the [Command History] or [Execute Command] dialog windows

may be invoked.
Current Objective area  - [New Optical Configuration] and [Optical Configurations] 

commands are available.
Profiler area  - [View Profile Results], [Reset Profiling], and [Enable Profiling] commands 

are available

Document Status Bar

Channel Tab area  - [Copy Channel], [Paste Channel], [Remove Channel], [View Channel 
In Color], and [Properties] commands are available.
Document Calibration area  - [(Re)calibrate Document] and [Calibrate Using Objective] 

commands are available when the current image is Uncalibrated. [Precision] of the 
calibration display, [Units] to work with can be set, and the [Recalibrate Document] and the 
[Set Document] as Uncalibrated commands are available when the current image is 
calibrated.
Mouse Position area  - Color space to show the pixel values in can be selected (if an RGB 
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image is opened). 
Image Info area  - [Show Dimensions in Units] and [Show Dimensions in Pixel] options 

are available (when the current document is calibrated).

Mouse Wheel

Zooming

The mouse wheel serves for zooming images in/out by default. Its behavior differs according to
the type of the currently opened document:

ND files containing Z  - browses through the Z stack of images.
Other document types  - zooms the image in/out.

[ Ctrl + mouse wheel ] - zooms in/out every image including the Z-ND files.

Auto Detection Tools

Some auto detection tools use the mouse wheel for adjusting the detection parameters. This
regards the [Auto Detect] tool of the [View > Analysis Controls > Binary toolbar], and of the
[View > Analysis Controls > Annotations and Measurements] control windows.

Vector Objects

Vector objects (report objects, annotations, interactive measurement objects) can be copied by
"drag and drop" while holding the [Shift] key down.

Select the object(s) (text, shape, interactive measurement).
Press [Shift] and drag the object somewhere.
A copy of the object is placed where you release the mouse button.

Default Color Settings

The default colors of vector objects can be set in the following way (each annotation tool keeps its
own color, manual measurement objects share the color settings):

Draw a vector object.
Right click the object and select [Properties] from the pull-down menu. A dialog window 
appears.
Adjust the color (and other) settings and confirm them with [OK].
The settings will be used when drawing subsequent objects of the same type.
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Database module

NIS-Elements offers a database tool to efficiently manage images along with additional
information. After you install the Database module, the [Database] menu appears in the main
toolbar.

A database is an organized body of related information. It consists of one or more database
tables filled with data. Before you can start filling the tables, you need to create a new empty
database. This can be done by selecting the [Create database] command from the Database
menu.

Creating database

Select the Microsoft database engine in the
left list and the [Blank] template from the list
of templates. Click on the [Next] button.

Specify where the database file should be
stored on a disk - define the [Database File
Path] („C:\Databases\minerals.mdb“ for
example) and the database file name. You, as
the database creator, are automatically
considered as an administrator (the user name
and password are „[sa]“ by default). The
administrator is a user with all possible rights
to the database. Next, define a descriptive
name of a connection point, e.g [Test] for the
testing database. Click [Finish] and an empty
database is created and connected through a
connection point (see below).
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Creating tables

A database can contain one or more tables to
store your data to. Select the [Create table]
command from the Database menu.

Select the session from the left list. In our
case, there should be only one: „[Test(sa)]“.
It means: the user „sa“ is connected to the
database through the „Test“ connection point.
It is posssible to have one user connected to
more databases or more users connected to
the same database on one system. On the
right side, choose the [Blank] template and
click the [Next] button.

Enter the [Name] of your new Table (e.g.
Minerals). The Description editbox isn‘t
necessary to fill, but it might prove helpful to
put down a short comment.

Define the table fields. First, click to the
[Name] field and fill it in (e.g. Author). Press
[Enter] and define the data type of this field.
This is done by selecting one option from the
combo box, which opens after clicking into the
[Type] field. Select the [Text] type, because
names are usually short enough to fit in this
data type. The [Is title] field determines,
which database entry is used as a description
of images while viewing the table using the
thumbnails view of Organizer. Define all fields
you want to include in the database table and
click [Finish]. The new table is created.

Special Field Types

Let‘s assume that pictures come from a closed group of people. In this case it is
usefull to set the field type of the „Author“ field to [Enumeration]. The
Enumeration value edit box on the right becomes active and you can enter all
names of possible authors. When adding a new image to the database later,
you can just select the author`s name from the combo box instead of having to
type it.

Another special field type enables to insert arbitrary external links into
database tables. Select the [External Link] option as the field type. Later, you
can insert a command, link to a website etc. to these fields.
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File Field Mapping

It may be very handy to insert some image properties to the database. Therefore the [File field
mapping] can be used to map file properties (such as filename, file date, calibration, author etc.)
included in the image file to the table fields. Select the information type from the combo box. If
the <default value> is selected, fill in the [Default] value text box and that text will be used for
every database entry added to the table.

Managing Tables

After you have created one or more tables, you can
manage them easily using the [Remove Table] and
[Modify Table] commands from the Database menu.
Each command opens a dialog window.

The Modify Table command asks you to select a table to
modify and opens the table properties window.

The Remove Table command removes a table from a
database. However, the database images may
optionally not be deleted. A directory to store images of
each table is created during the table creation. The
directory has a name that matches the name of the
table and is placed in the directory where the database
file is stored. Copies of the source files from your disk
are created in there for database purposes.

If you check the [Delete also images linked to the table] check box during the table removal, all
these copies are deleted from your disk. Otherwise, the copies remain untouched.
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Adding Images to Database

You have successfully created a database with
at least one table. Use it to store pictures with
descriptive information. Every time you choose
the [File > Save to Database] command, you
will be prompt to pick a table to write in. The
[Save] button invokes a window to fill the
database entry information and saves the
current image into that table. View the
database records in the [Organizer] view (the
[F10] hotkey).

Connecting to a Database

Connection Points

Connection points are intended to ease work with databases. A connection point has similar
functionality to file shortcuts or links. It can be named arbitrarily and you can access the
database through it. It is allowed to create and use one connection point per database here.

Let`s suppose you have a database created. Launch the [Create Connection Point] command.
Write the connection point name and select the path to the database file in the wizard that opens
(once you have created the connection point, you can manage user accounts and permissions of
the related database by selecting the [User Accounts and Permissions] command from the
Database menu). You can also create more or delete some connection points in the connection
points manager (Database menu > Connection Points submenu > Manage Connection Points
command).
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Connecting to Database

Use the [Connect] command
to connect to a database.
Select the connection point
(representing the database)
from the combo box. In case
this combo box is empty,
press the icon on the right side
to create a new connection
point.

Authentication

To access the database, a user authentication is needed. If the [Windows authentication] option
is chosen, the username and password of your windows account are used when logging in. [The
Native database authetication] requires entering the username and password which is valid for
the database you want to connect to. Click [OK] to connect.

Active Connections

You can view the list of active connections in the [Organizer] view (F10 key shortcut). The
[Disconnect] menu command displays the dialog box where you can select the connection point
to be disconnected. Disconnecting the point closes the way to save images to the corresponding
database for the user. Still, you can access the other databases through other connection points.

Every user who possess rights to the database administrator account (with the username „sa“ by
default) can manage other user accounts using the [User accounts and permisions] menu
command.
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User Accounts and Permissions

The [Create user] button displays a dialog
box (see below). The [Delete user] button
displays a confirmation dialog box - when
[OK] is pressed, the user is deleted.

The Change password button enables to set a
new password for the selected user. The
dialog box with two editboxes (the new
[Password] and its [Confirmation]) appears.
The [Change properties] button opens an
advanced dialog box where you can set
various user rights.

Create New User Account

The user creation allows you to choose
between the [Regular user] (this option
enables to create an arbitrarily named user)
and the [User from Windows account] (it is
possible to choose from users, who have a
windows account on the current computer).

Write a new user name to the [User name]
box or select existing user from the list of
windows accounts. You can add any
comments to the [Description] box. Enter a
[Password] twice ([Confirm Password]) and
[Create] the new user.

Multiple connections to databases using different user accounts are permitted. If some intended
operations are unavailable, check whether you are logged under the correct user account with
adequate rights.
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User Permissions

Having sufficient privileges, you may change
the other user`s accounts properties by
pressing the [Change properties] button in
the [User Accounts and Permissions] window.
The dialog box, where it is possible to set
user rights for various actions performed on a
database, opens. To set or ban the rights,
click into the check boxes. There are three
main sections in the dialog window: the [User
rights], [Tables] and [Fields].

The User rights section

This section is used to define, what actions are allowed for the selected user in relation to other
users and all databases. Decide, whether the user can delete, modify, create user accounts or
delete and create tables. The „[sa]“ (database administrator) user`s properties cannot be
modified nor that account can be deleted by other users.

The Tables section

Displays a list of existing tables. It is possible to set rights to view, create and delete whole
records, as well as rights to create and delete single fields of a table. When the [Delegate rights]
check box is checked, the user is allowed to modify permissions of other users for that table.
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The Fields section

More detailed settings for each table are listed here, if the table was selected in the [Tables]
section. You can only see the fields that your privileges allows you to view. You can set, if the
user will be able to view or modify every single field.

Changing Password

You can change a password to a
database via the [Change password]
command from the Database menu.
Enter your old password, and a new
one twice to prevent a typewriting
mistake. The [Change] button finishes
the operation. A user with a privilege
to „[Modify user]“ can change the
other user`s passwords via the User
Rights and Permissions menu
command.
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Database Backup

A possibility to backup the database is
essential and strongly recommended for any
serious work. The [Database Backup
Scheduler] enables the system to backup the
database automatically once in a precisely
specified time interval, so you do not have to
be afraid to loose any data. The Database
Scheduler uses the standard Windows
„[Scheduled Tasks]“ tool (Start > Control
Panel > Scheduled Tasks). Once you schedule
a backup, there is only one condition to
perform it succesfully: The computer must be
[ON] at the scheduled time.

Backup Settings

To set a new periodic backup, click the [New Task]
button. In the dialog window that appears, specify
the task name and click [OK]. If you already have
some task that suits your needs, it is possible to
copy its properties by checking the [Based on]
check box and choosing it s name from the list.
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Since the task is based on the Windows
component, it is necessary to run it
under a Windows user account. Either a
local or a domain account is allowable
(the domain name „[LAB]“ is used in our
example). After filling in the password,
decide, how often the backup shall be
performed. Daily, weekly, and monthly
intervals with a precision of seconds are
available.

Furthermore, the location of three following
files on a disk is needed. Use the [Browse]
buttons on the right side of the textboxes to
specify the paths to the [Source database]
file (the file to be backed up), the
[Destination (backup) database] (a directory
to which the backup file will be written) and
the [Backup log] file where the information
about the backup process is stored. The
specification of all three destinations is
mandatory. Without it, the backup cannot
start.

Detailed Backup Settings

In the Source database settings, there are the Database
account and Password text boxes. They are not editable
and are for information only.

Backup History

When performing a backup
periodically, the already existing (the
latest) backup file`s content is moved
to a new history file and a suffix with
the iteration number is attached to its
name. The new backup file is created.

This way, an unlimited number of the history backup files is being created on a disk. When you
limit the number of history files (e.g. to prevent the disk capacity overflow), each time the
scheduler replaces the latest file with the new one, it also renames all the other backup files
accordingly. As a result, the file names and their number on a disk remain the same (although
their content changes).
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Backup Logging

The amount of information to be written to the backup log file is
determined by the [Level] choice. The [Details] option records
changes of all files of a database compared to the previous backup.
If you choose to record the [Summary] only, possible critical errors
and backup process results are included in the log file.
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The Extended Depth of Focus Module

The EDF module allows you to combine existing Z-stack images into one focused image picking
the focused regions from each frame and merging them together. The "Align" algorithm ensures
correct fitting of pixels even for images acquired via macro optics, where objects are slightly
shifted or scaled during the z-stack acquisition.

When you start NIS-Elements with the EDF module installed, the following items appear in the
[Applications] menu:

Open File Sequence
Align Sequence
Create Focused Image
Edit Area in Focused Image
Real Time EDF
Real Time EDF Manually
Options

Open (or acquire) an ND2 document that includes the Z dimension. If you use the [Open File
Sequence] command to get the Z stack of images, a new ND document is created automatically.

Align Sequence

Small shifts of the images can occur as a result of hardware inaccuracies during the Z series
acquisition. To get reliable results out of the EDF module, the sequence that is to be processed
should be aligned first. Use the Align Sequence  command to automatically correct possible
shifts.

Select the method

Once the sequence is aligned, invoke the
[Options] command to select the preferred
method of creating the focused image. The
following dialog window appears:

Smooth (default)

The focused image is created step by step. In
each step, this method computes the focus
criterion for each pixel and compares them. It
has two parameters which you can change
according to the needs of a sequence.

Level  - Affects the smoothness of the 
focus criteria in the image. Higher 
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settings mean that the focused areas in the image will affect larger neighborhood. The 
default setting is Standard.
Blending  - When the focus criteria in the source frames are similar, the pixels from those 

frames can be combined and the transitions between the focused regions in the result image
will be smooth. The higher blending you select, the more differing pixels will be combined.

Local

This method computes the focus criteria in another way than the Smooth method. It finds the
focused regions of the source frames and copies them to the result image. An additional
processing of the regions removes the badly detected ones. However, borders (transitions)
between some regions might be clearly visible at the end.

Fluorescence

Similar to the Local method, but it uses different focus criteria optimized for fluorescence images.

Maximum intensity

The focus criterion is the intensity of each pixel. The pixels with the highest intensities of all
frames are copied to the result image.

Creation of the focused image

When the method is selected and the sequence is aligned, the only thing to do is to run the
[Create Focused Image] command. The focused image will be created and appended to the ND2
document (when the ND2 file is saved to disk the focused image is included.)

Viewing of the result

After the focused image is created, all buttons of the EDF tool bar
(located inside the document window) become enabled. There are three
ways to observe the resulting focused image, as:

A common Color/Gray image
An anaglyph - to be viewed using special 3D glasses.
A 3D model, using so called Surface View.

This button displays the focused result image.

Creating anaglyph

Using this button, you can create three-dimensional stereo images (anaglyphs). These 
images shall be observed with special glasses having red and green or blue filters. This 
provides a 3D impression. Click the nearby arrow button and select the [Anaglyph options] 

command. 
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The following dialog box appears.

The first frame is the

Defines the direction of the z-axis sequence. Can be highest or lowest

The result will

Defines the stereovision impression, which you will experience using special red-green glasses.
Can descend into the screen or rise from the screen.

Enhance sequence height

Enhances the depth feeling.

Gray-scale anaglyph

Creates a gray-scale anaglyph. If not checked, the anaglyph is color.

Left filter color

You can select the color of your glasses. This option is crucial to get the right 3D impression.
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Exploring the 3D model

This button runs the built in 3D viewer.

The 3D viewer displays the surface of a captured object three-dimensionally.

For proper view, it is necessary to set whether the first frame in the sequence is the lowest 
or the highest one (set this by the leftmost icon).
You can also adjust the sequence height for more credible look via the [Z-zoom] combo box.
Navigate the view by sliders on sides or by mouse. A mouse wheel serves for zooming.

The 3D model can be exported to VRML (Virtual reality modeling language) format for distributing
and viewing outside of NIS-Elements software. This format is platform independent and is used
mainly on the internet.

To export the image to VRML, press the [Export to VRML] button. Two files will be saved. One
that contains the 3D information (WRL) and the other that is a 2D texture (JPG). Mind, that both
files must be distributed (e.g. placed on the web) together!

To view files in VRML format some VRML viewer is needed. The viewer is a plugin to your web
browser. There are several viewers available for free:

Cosmo Player  - http://ovrt.nist.gov/cosmo
Cortona  - http://www.parallelgraphics.com
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Edit Area in Focused Image

This advanced option enables you to draw an area inside the image and select the Z slice to be
used in the resulting focused image.

Display the focused image.
Select the [Edit Area in Focused Image] command.* The cursor changes.
Draw an area inside the focused image which should be affected. Finish drawing by 
right-click.
Use the mousewheel or arrow keys to browse Z slices within the area. 
Finish the procedure by right-click or [Enter].

* - when you have the area defined, the selection can be inverted by pressing [G].

Real Time EDF

The [Real Time EDF] command is integrating the whole functionality of EDF. It captures a
Z-sequence, aligns the images (optionally), and creates the focused image. When the [Real Time
EDF] command is invoked, the [Capture Z Series] dialog window appears with the [Align images]
check box added. There you can set whether to align the images or not.

If the [Real Time EDF Manually] command is used, not requiring to posses a motorized Z-drive,
the [Acquire > Capture Z Series > Capture Manually] dialog window appears with the [Align
images] check box added. It behaves the same as the [Real Time EDF] procedure except for the
manual way of capturing the Z sequence.

Please, see more details about the dialog window in the [ Z Series Capturing ] chapter.
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Deconvolution Module (AR)

Introduction

What is deconvolution for?

Deconvolution is a mathematical algorithm for removing unsharpen parts of image that lays out
of the focused plane.

How does it work?

The algorithm uses image information from different Z-slices. The input is a set of Z-slices
captured by a fluorescence microscope. The output is another set of slices, but, the image
information of each slice which does not belong to its focus plane is suppressed.

The algorithm used is: constrained iterative - maximum likelihood estimation algorithm (the
actual name of the algorithm is "Richardson-Lucy")

Results

The resulting image should look similarly as if captured by a confocal microscope.
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Get a Z sequence of images

Open a Z series ND2 document.

Invoke the [ File > Open ] command and select an ND2 document to be opened. It must contain
the Z dimension.

Acquire Z-series

Another option is to acquire a sequence of Z slices using the [ Acquire > Capture Z-Series
Automatically ] or the [ Acquire > Capture Z-Series Manually ] commands.

Deconvolve the Z Stack image

Run the [Applications > Deconvolution > Deconvolve Z Series] command and set the
deconvolution parameters:

Select your microscopy Modality , wide-field or confocal.
Fill-in the numerical aperture  (NA) value of the objective used.
Fill-in the refraction index  of the immersion medium used. There are some values 
predefined in the nearby menu (air, water, immersion oil, glycerin).
Fill-in the calibration field. Mind that the deconvolution doesn't work on uncalibrated 
sequences .
Pick the channels to deconvolve in the Channels  field.
Fill-in the emission wavelengths ( EmW ) of the channels. These values don't have to be 
accurate because they affect the result only slightly.
Fill-in the Z-Step  distance between the slices of your sequence.*
Press the Deconvolve  button.

* - It is important to fill the same value that was used during the Z Series acquisition. The
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deconvolution will not work properly without a reasonable Z-Step value. When you are about to
capture a Z sequence, you should [ set the Z-step value ] to [Suggested step size] or smaller in
order to get enough detail for the deconvolution algorithm to work fine.



170

The 2D Real-Time Deconvolution Module (AR)

Deconvolution is an image processing
technique that removes inaccurate
features in an image which are caused
by the optical path. It is usually used
for enhancing blurred images. RT
Deconvolution algorithm enables high
speed processing, therefore it is very
suitable for use on Live signal from
cameras. Real-time deconvolution can
be apllied to Live image continuously or
when capturing only. It can be also
used for processing saved images.

There is an example of Real time
deconvolution applied to rectangular
region of interest.

When you start NIS-Elements with the 2D Real-Time Deconvolution module installed, the
[RTDeconv] section appears in the [Applications] menu with the [ Show RT Deconvolution Setup ]
and the [ Enhance Current Image... ] commands. Click the first command to display the following
control window.
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Use 2D Real-Time deconvolution

This option switches on/off the deconvolution on Live image. When a static document is opened,
the Apply  button appears instead of this option.

Microscope Settings

Microscope Settings are the input parameters for the deconvolution.

Numerical aperture

NA of the objective lens. This value is written on the objective itself.

Refraction index

Refraction index of the lens immersion medium (typically 1.00 for air, 1.33 for water, 1.51 for
immersion oil, 1.61 for glycerin).

Emmission wavelength

Emission wavelength of the fluorescent specimen in nm. Use 520nm if unsure.

Specimen thickness

Describes how thick the is the specimen being imaged. The value is typically between 1 and 5.
Use 1 for optically flat mono-layers, and 5+ for thicker specimens.

Enhancing

Enhancing group controls the noise amplification vs. image smoothness. The default setting is
suitable for low-noise images.

Smoother

Press this button to decrease the noise.

Sharper

Press this button to increase the sharpness of the image.

Default

Return to default (std) setting.

Region of Interest (ROI)

Region of interest specifies the part of the image where the deconvolution will be done. Reducing
the area for the deconvolution will increase its speed.

Entire image

Check this option if you want to deconvolve the entire image.
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Position (x, y)

Top-left corner of the rectangle representing the ROI.

Size (x, y)

Width and height of the rectangle representing the ROI.

Define...

If you press this button, you can draw and/or adjust the rectangle with mouse directly in the
image.

"Not calibrated!"

It is necessary to have the image calibrated in order for the deconvolution to work. If you see this
message, you should calibrate the image or the optical configuration  you use.
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AutoQant Deconvolution Module (AR)

Introduction

What is deconvolution?

Deconvolution is a mathematical algorithm for removing unsharpen parts of image that lays out
of the focus plane.

How does it work?

The algorithm uses image information from different Z-slices. The input is a set of Z-slices
captured by a fluorescence microscope. The output is another set of slices, but, the image
information of each slice that does not belong to its focus plane is suppressed.

Getting a Z sequence of images

Invoke the [ File > Open ] command and select an ND2 document to be opened. It must 
contain the Z dimension.
Acquire a sequence of Z slices using the [ Acquire > Capture Z-Series Automatically ] or the 
[ Acquire > Capture Z-Series Manually ] command.

Results

The resulting image should theoretically look similarly as if captured by a confocal microscope.
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To deconvolve a Z Sequence

Run the [Applications > AutoQuant Modules > Deconvolution] command and set the
deconvolution parameters:

Microscopy Settings

These values which give information
about the microscope settings are
usually retrieved from the captured
document (except [Modality]).
However, they can be modified by
user.

Select microscope Modality:

widefield fluorescence
transmitted-light brightfield
laser scanning confocal
spinning disk confocal
multi-photon fluorescence

Numerical Aperture

Fill-in the [NA] value of the objective
used.

Refraction index

Fill-in the [refraction index] of the
immersion medium used. There are
some values predefined in the nearby
pull-down menu (air, water,
immersion oil, glycerin).

Calibration

Fill-in the [Calibration] field. Mind
that deconvolution doesn't work
on uncalibrated sequences .

Z-Step

Fill-in the [Z-Step] distance between
the slices of your sequence.
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Channels

Pick the channels to be processed by selecting check boxes within the table of image channels.
The channel name, emission wavelength, and spherical aberration are also retrieved from the
document or can be modified by user.

EmW

These values don't have to be accurate because they affect the result only slightly. To modify
EmW, select the channel to which you are setting the emission wavelength, and fill the new EmW
value inside the [Emission wavelength] field.

Spherical Aberration

To modify the spherical aberration setting, select the channel to modify, and move the slider
left/right. The button above the slider resets the [SA] value.

Deconvolution Settings

Number of iterations

Specify how many times you would like to perform the deconvolution algorithm.

Noise level

Select the level of noise present in the images (low, medium, high)

Faster processing/ Reduced resolution

Resolution of the result can be reduced on behalf of the processing speed (the resolution will be
reduced temporarily during the processing. Afterwards, the original resolution will be renewed).
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Calcium and FRET module (AR)

Installing the Calcium and FRET module adds several tools regarding the FRET analysis method to
the system:

A control window suited for capturing FRET images.
Automated FRET calibration algorithm.
The [Create FRET Image] dialog window for "passive" creating FRET images from files.

Capturing FRET image, FRET calibration

Run the [Applications > FRET > Capture FRET Image] command to display the main FRET control
window. Select the appropriate settings and capture the FRET image by the [Capture FRET]
button.

Hardware Setup

The FRET control window consists of several sections. In this section, optical configurations which
will be used durint the acquisition should be assigned to FRET channels.

Camera Setting

In this pull-down menu, select an
optical configuration that contains
[Camera settings] which shall be
used during the FRET image
acquisition. If [None] is selected,
the current camera settings will
be used.

Channels

The FRET image can contain 2-4
channels. Here you can assign an
optical configuration to each of
them. It is recommended that the
optical configuration contains only
the filter changer settings.

Dual View

If the Dual View device is
available, it can be used for
channel splitting. Then, only one
optical configuration for each
excitation wavelength will be used.

The Dual View device splits the emitted light to two beams filtering different wavelengths, and
each of them is captured by only a half of the camera chip.
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Load/Save

The channels settings may be saved to the system by the [Save] button. Once saved under some
user defined name, this name appears in the [Load] pull-down menu ready to be loaded. The
settings can also be loaded from an external FRET image.

FRET Calibration

Separate images of the D-labelled and the A-labelled samples must be be acquired in order to
calibrate the FRET method correctly.

Insert the D-labelled sample. Press the [Capture Donor Only Sample] button.
A new document will be captured and named "Donor".
Insert the A-labelled sample. Pres the [Capture Acceptor Only Sample] button.
A new document will be captured and named "Acceptor".
Press the [Calibrate] button to display the calibration dialog.

Select the "Donor" image and the "Acceptor" image in the appropriate pull-down menus.
The [Define ROI] and the [Define Background ROI] buttons enable to distinguish the 
foreground/background parts of the images.
Draw the background/foreground ROIs.
Confirm the calibration by [OK].

Any image file can be used for the calibration. The pull down menu displays the currently opened
images. Other images can be reached via the [Browse] button. If a non-FRET image is used, a
dialog window appears where you should map the image channels to FRET channels and select
the FRET method.

FRET Method

In this section, select one of the two available FRET methods.

FRET coefficients

There can be 2 or 4 coefficients used according to the method. Their values are results of the
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calibration. If the calibration was not performed, you can put the coefficients in by hand. The
coefficients settings can be saved/loaded similarly to the channels settings.

Creating FRET image

The FRET image can be created from images saved on harddisk too. Run the [Applications > FRET
> Create FRET Image] command. A dialog window appears. The FRET image creation principles
are the same as if capturing the FRET image except that you provide the module with mono
images from harddisk (instead of capturing them via a camera).

Select a mono image from the pull-down menus for each FRET channel. Their previews 
appear. 
Select a method, calibrate the module, modify the coefficients (similarly as if capturing the 
FRET image). Confirm the settings with [OK].
A new FRET document is created and opened within the application screen.

Calcium Calibration

The module provides the methods for the efficient calcium ion concentration measurement.
Calcium calibration, graph display, and image display in terms of Ca2+ concentration is available.
All constants necessary for calcium ion concentration calculation can be defined manually within
the [Ratio Properties] dialog window. Or, the Rmin/max and Fmin/max constants can be picked
from the graph.
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Devices

Before you get to work with NIS-Elements, all hardware accessories should be connected properly
to the system. In most cases, the following basic procedure is sufficient to connect a device
succesfully:

Install NIS-Elements, and select the appropriate devices during the installation. 
Connect the device to a PC and switch the device ON.
Run NIS-Elements, and run the [Devices > Manage Devices] command to open the Device 
Manager.
Use the [Add] button to add the device to NIS-Elements.
Select the device in the devices list and press the [Connect] button.
Select logical devices to be activated.
Configure device-specific settings using the [Configure (physical) Device] and the [(logical) 
Device Parameters] buttons.
[Close] the Device Manager.

Logical Devices

NIS-Elements handles hardware accessories using the concept of logical devices. There are some
features of different hardware devices which equal, and therefore can be controlled equally. Such
features are called "logical devices" for purposes of NIS-Elements. A typical logical device is
[Stage XY]. Different microscopes can be equipped with different XY motorized stages, although -
regarding the user interface - they behave equally. One physical device (a piece of hardware) can
contain one or more logical devices, the list of which appear in the Device Manager after
connecting it to NIS-Elements.

Available Logical Devices

Analyzer

The analyzer is a polarizing filter placed in the optical path before the specimen. The logical
device offers two states: ON (inserted) and OFF (extracted).

Aperture

This logical device is used for controlling apertures in the light path. It is used in complex
microscopes rather than as a standalone device. Typically it contains two controls. One for
switching it ON and OFF (typically a button), and the other for specifying its size (typically an
edit-box or a slider).

Condenser

A condenser is a two-lens combination located next to the light source in the optical path. Its
purpose is to collect light and direct it onto the object being examined. The corresponding logical
device relates to a changer of different condensers.
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Filter

This logical device controls filter changer movements. There can be several filter changers
connected to NIS-Elements at a time. Each filter changer needs to be set up - filter types shall be
assigned to positions of the changer:

Display the filter changer control window ([Devices > Filters & Shutters] or [Devices > 
Microscope Control Pad]).
Click the the setup ([...]) button, a dialog window appears.
Select one of the available positions which the filter will be assigned to.
Select the filter name from the [Predefined]/[Custom] list of filters.
Click the [<-Set] button
The filters can be moved within the already defined positions using the [Up/Down] arrow 
buttons.

When browsing the list of filters, details about the currently selected filter are displayed in the
right-most portion of the window.

Light

This logical device is used for controlling the specimen illumination remotely. There is not any
standard dialog box for the light control. Each device handles this logical device via a specially
designed user interface - typically containing one button for ON/OFF switching and a slider for the
intensity regulation.

Light Path

Some microscopes have more than one port where it is possible to attach a light source or a
camera. This logical device can switch the light between these ports.

Microscope

This logical device is used to group standalone logical devices used in microscopes. To control the
logical devices of a microscope from one control window, select the [Devices > Microscope Control
Pad] command.

Nosepiece

This logical device serves for controlling microscope objective changers. There can be three
nosepiece types attached to a microscope:

Manual  - it can not be controlled via the [Microscope Control Pad] or the [Nosepiece]
control window. 
Intelligent  - the current nosepiece position is indicated, but can not be controlled.
Motorized  - such nosepieces can be fully controlled via the [Microscope Control Pad] or 

the [Nosepiece] control window.

Assigning objectives

To assign an objective (or to change an attached objective assignment) to a position, click 
the setup ([...]) button.
A dialog window appears which enables you to select on of the available objectives to the 
corresponding position.
Each objective has its specifications displayed in the table. These specifications are not 
editable.
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ND Filter

A neutral-density filter is a light absorbing filter whose absorption spectrum is moderately flat. It
is used to reduce the light intensity within the optical path. The logical device offers two states:
ON (inserted) and OFF (extracted).

PFS

Perfect Focus System - this logical device corresponds to the PFS physical device available with
Nikon TE2000/TI microscopes.

Shutter

This logical device can control shutters installed in your system. This device is handled via the
[Devices > Filters & Shutters] control window or straight from the microscope control pad.

Zoom

This logical device is used for controlling the zoom factor. Run the [Devices > Zoom
Configuration] command to adjust the zoom settings.
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Nikon Eclipse 90i/80i Microscope

The 80i/90i (fully armed) Microscope
Control Pad consists of the following
portions:

Nosepiece

This portion depends on the type of
the connected nosepiece:

Manual  - it remains hidden
Intelligent  - it indicates the 

current nosepiece position, but 
can not be controlled.
Motorized  - it can be fully 

controlled.

Lamp

The light path accessories that affects
light intensity can be controlled here.
The condenser turret is controlled by
selecting the desired condenser from
the pull-down menu.

Z Drive

The Z drive movements are
indicated/performed via the scrollbar.
Tollerance (precision) can be set in
the pull-down menu. The higher the
tollerance is, the faster the Z drive
moves, though less precisely.

Filter Block Changer

The standard motorized filter
changers control.



183

Nikon AZ100 Microscope

When AZ100 is connected to
NIS-Elements, the manual remote
control gets disabled automatically.
The AZ100 Microscope Control Pad
consists of the following portions:

Objectives

The objectives portion of the pad
indicates the nosepiece status: the
currently selected objective and
objectives magnification. The objective
changer cannot be controlled by
NIS-Elements.

Zoom

Zoom magnification can be changed by
moving the scroll bar. The current
zoom factor is indicated above. Since
the zoom device is a part of the
microscope equipment, concerning
optical configurations, its settings are
automatically treated as an
inseparable part of [microscope
settings].

Condenser

The green button indicates the current
condenser lense position (Low/High).
The condenser cannot be controlled.

Z Drive

The Z drive can be controlled via the microscope control pad in the following way:

The [up/down arrows] move the Z drive by a defined [Step].
The current position can be memorized by pressing the [Set] button. The position value will 
be written to the pull-down menu.
To move the Z drive to a memorized position, select the desired value from the pull-down 
menu and press the [Go] button.
The current position is indicated below the [Step] edit box.

FilterBlocks

The currently selected filter of the four available filter positions is indicated in the Filter Blocks
portion of the pad. The filter changer cannot be controlled by NIS-Elements. Filters assignment
may be changed after pressing the [...] button.
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Nikon Eclipse LV Series Microscope

The LV (fully armed) Microscope
Control Pad consists of the following
portions:

Nosepiece

The motorized objective changer can
be controlled via this portion of the
dialog window.

Accessories

Intensity of episcopic and diascopic
light sources can be controlled.

Z Drive

The motorized Z drive is controllable
too. Clicking the arrow buttons moves
Z drive by the step defined in the
pull-down menu. The [Escape] button
clears the objectives of the stage
reach. The bottommost position
(lower limit) of the Z drive can be set
using the [Set Limit] button. The
[Clear Limit] button discards the
setting.

Please make sure to set [Lower limit]
before using the microscope.
Otherwise, the objective can
accidentally hit the stage when the
motorized Z drive moves.

Filter Blocks

There are 4 available positions in the
changer. The first two have fixed
filters for bright field (BF) and dark
field (DF) microscopy. The other two
are available for any filters to be
inserted.
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Nikon MM 400/800 Microscopes

The measuring microscope connected to NIS-Elements provides two logical devices:

Nosepiece

Two types of nosepiece can be attached to the microscope:

Manual  - cannot communicate with the computer. Each time you switch the objectives, 
you should also select a position in the Nosepiece control window accordingly.
Intelligent  - cannot be controlled by the system, but when you change the objective 

manually, it indicates the change in the Nosepiece control window automatically.

After adding the MM microscope to the system via Device Manager, the [Nosepiece] logical device
becomes available. Display its control window by the [View > Acquisition Controls > Nosepiece]
command. The type of the nosepiece must by defined via the hardware control pad in order to be
recognized by NIS-Elements

Z Drive

The Measuring Microscopes Z drive may be moved using the [View > Acquisition Controls > XYZ
Navigation] control window.
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Nikon TE2000 Microscope

The TE2000 (fully armed) Microscope
Control Pad consists of the following
portions:

Nosepiece

The motorized objective changer can be
controlled via this portion of the dialog
window.

Light

Complete light path accessories can be
controlled here. Switch the light between
ports as needed.

Condenser

The condenser turret is controlled by
selecting the desired condenser from a
pull-down menu.

Z Drive

The Z drive position is indicated, or can
be controlled, via a scrollbar.

PFS

The functionality of the PFS-section of
the control pad corresponds to the
hardware controller.

Filter Changers

Standard motorized filter changer
controls. You can select whether filter
colors or position numbers are displayed
on the buttons.
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Nikon TI Microscope

The TI (fully armed) Microscope Control Pad
consists of the following portions:

Nosepiece

The nosepiece can be controlled here. The
objective settings are being shared between
NIS-Elements and the microscope RCP.

Light Path

The light path control buttons correspond to
the buttons placed on the microscope body.

PFS

This optional accessory can be controlled via
the pad. The offset value can be put straight
in the edit box. When you are about to turn
the PFS ON, make sure the [Focus] indicator
shines. It indicates that the PFS is ready to
get to the defined offset position.* The
[Memory] and [Recall] buttons equal the
buttons on the microscope body.

* - Vast shift of the Z drive can cause that
PFS will not be able to refocus. That is when
the [Focus] indicator stops shining.

Z Drive

The integrated Z drive movements are
performed by the up/down arrows. Tollerance
(precision) can be set in the pull-down menu
on the right. The tollerance setting affects
the Z drive speed slightly.

Lamp

Three types of illumination devices can be
attached: Diascopic lamp, Intensilight fiber
illuminator, TIRF illuminator. All these devices
are controllable by the pad.

TIRF  - A shutter can be assigned to close
every time the TIRF position is being
changed. To do so, right-click the TIRF logical
device within the [Device Manager] window
and select the shutter type from the context menu.
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Shutters

Register the correct shutter types in the RCP. Then, the shutters can be controlled by
NIS-Elements.

Piezo Z

An optional piezo stage is controlled equally to the Z Drive device. The piezo Z component should
be registered via RCP, and direct USB cable must be used between PC and the microscope body
(not the HUB connection).

Filters

The standard motorized filter changer control. The [Analyzer] button appears, when the
[ANALYZER] filter type is assigned to one position of the turret. Press the [IN/OUT] button to
insert/extract the analyzer.

Condenser

The condenser turret is controlled by selecting the desired condenser from the pull-down menu.


